# CVE-2026-23495: Pimcore's Admin Classic Bundle is Missing Function Level Authorization on "Predefined Properties" Listing

> Authenticated users without property management permissions can access the full list of predefined property configurations via an unprotected API endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-hqrp-m84v-2m2f

## What is CVE-2026-23495?

CVE-2026-23495 is a medium-severity missing authorization vulnerability in pimcore, published on 15 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. Prior to 2.2.3 and 1.7.16, the API endpoint for listing Predefined Properties in the Pimcore platform lacks adequate server-side authorization checks. Predefined Properties are configurable metadata definitions (e.g., name, key, type, default value) used across documents, assets, and objects to standardize custom attributes and improve editorial workflows, as documented in Pimcore's official properties guide. Testing confirmed that an authenticated backend user without explicit permissions for property management could successfully call the endpoint and retrieve the complete list of these configurations. The vulnerability is fixed in 2.2.3 and 1.7.16.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-23495?

4 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.16 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.16 |
| `pimcore/admin-ui-classic-bundle` | Packagist | From 2.0.0-RC1 | 2.2.3 |
| `pimcore/admin-ui-classic-bundle` | Packagist | From 2.0.0-RC1 | 2.2.3 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2026-23495?

Upgrade pimcore/admin-ui-classic-bundle to a fixed version for your release line: 1.7.16 or 2.2.3.

## Is CVE-2026-23495 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23495 exists.

## Other vulnerabilities in pimcore

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23495 and fix it if it is affected.

What it is: CVE-2026-23495 is a medium-severity missing authorization vulnerability in pimcore, published on 15 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23495 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.16
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.16
- pimcore/admin-ui-classic-bundle (Packagist): affected from 2.0.0-RC1; fixed in 2.2.3
- pimcore/admin-ui-classic-bundle (Packagist): affected from 2.0.0-RC1; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23495/ (Markdown: https://insights.sbomify.com/CVE-2026-23495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23495
- OSV: https://osv.dev/vulnerability/CVE-2026-23495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23495/
Summaries are generated and may contain mistakes; the official description above is the record.
