CVE-2026-23496 Pimcore Web2Print Tools Bundle "Favourite Output Channel Configuration" Missing Function Level Authorization
Authenticated users lacking specific permissions can modify or retrieve Favourite Output Channel Configurations due to missing server-side authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23496?
CVE-2026-23496 is a medium-severity missing authorization vulnerability in pimcore, published on 15 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Pimcore Web2Print Tools Bundle adds tools for web-to-print use cases to Pimcore. Prior to 5.2.2 and 6.1.1, the application fails to enforce proper server-side authorization checks on the API endpoint responsible for managing "Favourite Output Channel Configurations." Testing revealed that an authenticated backend user without explicitely lacking permissions for this feature was still able to successfully invoke the endpoint and modify or retrieve these configurations. This vulnerability is fixed in 5.2.2 and 6.1.1.
Which versions are affected by CVE-2026-23496?
4 open source packages ship an affected version, including pimcore/web2print-tools-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pimcore/web2print-tools-bundle Packagist | All versions | 5.2.2 |
pimcore/web2print-tools-bundle Packagist | All versions | 5.2.2 |
pimcore/web2print-tools-bundle Packagist | From 6.0.0-RC1 | 6.1.1 |
pimcore/web2print-tools-bundle Packagist | From 6.0.0-RC1 | 6.1.1 |
Products include Pimcore Web2print Tools.
How do I fix CVE-2026-23496?
Upgrade pimcore/web2print-tools-bundle to a fixed version for your release line: 5.2.2 or 6.1.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-23496 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23496 exists.
Sources
Also known as GHSA-4wg4-p27p-5q2r.