CVE-2026-23498 Shopware Improper Control of Generation of Code in Twig rendered views

High 7.2 Published Updated

Attackers can execute arbitrary code via crafted PHP closures in Twig views due to insufficient allow-list checks in Shopware.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-23498?

CVE-2026-23498 is a high-severity code injection vulnerability in Shopware Shopware, published on 14 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.

Weakness: CWE-94

Which versions are affected by CVE-2026-23498?

4 open source packages ship an affected version, including shopware/core and shopware/shopware. It affects 1 product.

PackageAffectedFixed in
shopware/core PackagistFrom 6.7.0.06.7.6.1
shopware/core PackagistFrom 6.7.0.06.7.6.1
shopware/shopware PackagistFrom 6.7.0.06.7.6.1
shopware/shopware PackagistFrom 6.7.0.06.7.6.1

Products include Shopware Shopware.

How do I fix CVE-2026-23498?

Upgrade shopware/core to 6.7.6.1 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-23498 being exploited?

There is no known exploitation of CVE-2026-23498 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-7cw6-7h3h-v8pf.

Is CVE-2026-23498 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free