# CVE-2026-23500: Dolibarr: OS Command Injection (RCE) via MAIN_ODT_AS_PDF configuration

> An authenticated administrator can achieve remote code execution by injecting OS commands into the ODT to PDF conversion configuration setting.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Apr 2026
- **Updated:** 18 Apr 2026
- **Also known as:** GHSA-w5j3-8fcr-h87w, UBUNTU-CVE-2026-23500

## What is CVE-2026-23500?

CVE-2026-23500 is a critical command injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Dolibarr is an enterprise resource planning (ERP) and customer relationship management (CRM) software package. In versions prior to 23.0.0 , the ODT to PDF conversion process in odf.php concatenates the MAIN_ODT_AS_PDF configuration constant directly into a shell command passed to exec() without sanitization. An authenticated administrator can inject arbitrary OS commands via this constant using command separators, achieving remote code execution as the web server user when any ODT template is generated. This issue has been fixed in version 23.0.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-23500?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions to 22.0.4 | None |
| `dolibarr/dolibarr` | Packagist | All versions to 22.0.4 | None |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2026-23500?

No fix has been published for CVE-2026-23500 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-23500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23500 exists.

Public exploit code:

- CVE-2026-23500 - OS Command Injection (RCE) via MAIN_ODT_AS_PDF configuration in Dolibarr (github_poc): https://github.com/lukasz-rybak/CVE-2026-23500

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23500 and fix it if it is affected.

What it is: CVE-2026-23500 is a critical command injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 17 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23500 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions up to 22.0.4; no fix listed
- dolibarr/dolibarr (Packagist): affected all versions up to 22.0.4; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23500/ (Markdown: https://insights.sbomify.com/CVE-2026-23500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23500
- OSV: https://osv.dev/vulnerability/CVE-2026-23500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23500/
Summaries are generated and may contain mistakes; the official description above is the record.
