# CVE-2026-23515: RCE - Command Injection in Signal K set-system-time plugin

> Authenticated users or unauthenticated users with disabled security can execute arbitrary shell commands via WebSocket messages in the set-system-time plugin.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 3 Feb 2026
- **Also known as:** GHSA-p8gp-2w28-mhwg

## What is CVE-2026-23515?

CVE-2026-23515 is a critical command injection vulnerability in signalk-server, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Signal K Server is a server application that runs on a central hub in a boat. Prior to 1.5.0, a command injection vulnerability allows authenticated users with write permissions to execute arbitrary shell commands on the Signal K server when the set-system-time plugin is enabled. Unauthenticated users can also exploit this vulnerability if security is disabled on the Signal K server. This occurs due to unsafe construction of shell commands when processing navigation.datetime values received via WebSocket delta messages. This vulnerability is fixed in 1.5.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-23515?

2 open source packages ship an affected version, including @signalk/set-system-time. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@signalk/set-system-time` | npm | All versions | 1.5.0 |
| `@signalk/set-system-time` | npm | All versions | 1.5.0 |

Products: Signalk Signal K Server.

## How do I fix CVE-2026-23515?

Upgrade @signalk/set-system-time to 1.5.0 or later.

## Is CVE-2026-23515 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23515 exists.

## Other vulnerabilities in signalk-server

- [CVE-2025-66398](https://insights.sbomify.com/CVE-2025-66398/): Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE) (critical 9.7)
- [CVE-2026-33950](https://insights.sbomify.com/CVE-2026-33950/): signalk-server: Privilege Escalation by Admin Role Injection via /enableSecurity (critical 9.4)
- [CVE-2025-68620](https://insights.sbomify.com/CVE-2025-68620/): Signal K Server vulnerable to JWT Token Theft via WebSocket Enumeration and Unauthenticated Polling (critical 9.1)
- [CVE-2026-41893](https://insights.sbomify.com/CVE-2026-41893/): Signal K Server's WebSocket Login Endpoint Lacks Rate Limiting (Credential Brute-Force) (high 8.7)
- [CVE-2026-39320](https://insights.sbomify.com/CVE-2026-39320/): Signal K Server has an Unauthenticated Regular Expression Denial of Service (ReDoS) via WebSocket Subscription Paths (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23515 and fix it if it is affected.

What it is: CVE-2026-23515 is a critical command injection vulnerability in signalk-server, published on 2 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23515 exists.

Affected packages and fixed versions:
- @signalk/set-system-time (npm): affected all versions; fixed in 1.5.0
- @signalk/set-system-time (npm): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23515/ (Markdown: https://insights.sbomify.com/CVE-2026-23515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23515
- OSV: https://osv.dev/vulnerability/CVE-2026-23515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23515/
Summaries are generated and may contain mistakes; the official description above is the record.
