CVE-2026-23517 Fleet has an Access Control vulnerability in debug/pprof endpoints
Low-privilege users can access debug endpoints to view sensitive server internals and trigger denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23517?
CVE-2026-23517 is a medium-severity missing authorization vulnerability in fleetdm fleet, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Fleet is open source device management software. A broken access control issue in versions prior to 4.78.3, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 allowed authenticated users to access debug and profiling endpoints regardless of role. As a result, low-privilege users could view internal server diagnostics and trigger resource-intensive profiling operations. Fleet’s debug/pprof endpoints are accessible to any authenticated user regardless of role, including the lowest-privilege “Observer” role. This allows low-privilege users to access sensitive server internals, including runtime profiling data and in-memory application state, and to trigger CPU-intensive profiling operations that could lead to denial of service. Versions 4.78.3, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 fix the issue. If an immediate upgrade is not possible, users should put the debug/pprof endpoints behind an IP allowlist as a workaround.
Weakness: CWE-862
Which versions are affected by CVE-2026-23517?
11 open source packages ship an affected version, including github.com/fleetdm/fleet and github.com/fleetdm/fleet/v4. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/fleetdm/fleet Go | From 4.75.0 | 4.75.2 |
github.com/fleetdm/fleet Go | From 4.75.0 | 4.75.2 |
github.com/fleetdm/fleet Go | From 4.76.0 | 4.76.2 |
github.com/fleetdm/fleet Go | From 4.76.0 | 4.76.2 |
github.com/fleetdm/fleet Go | From 4.77.0 | 4.77.1 |
github.com/fleetdm/fleet Go | From 4.77.0 | 4.77.1 |
5 more packages
github.com/fleetdm/fleet Go | From 4.78.0 | 4.78.3 |
github.com/fleetdm/fleet Go | From 4.78.0 | 4.78.3 |
github.com/fleetdm/fleet/v4 Go | All versions | 4.78.3-0.20260112221730-5c030e32a3a9 |
github.com/fleetdm/fleet/v4 Go | All versions | 4.78.3-0.20260112221730-5c030e32a3a9 |
github.com/fleetdm/fleet/v4 Go | From 4.75.0 | 4.75.2, 4.76.2, 4.77.1, 4.78.3 |
Products include Fleetdm Fleet.
How do I fix CVE-2026-23517?
Upgrade github.com/fleetdm/fleet to a fixed version for your release line: 4.75.2, 4.76.2, 4.77.1 or 4.78.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-23517 being exploited?
There is no known exploitation of CVE-2026-23517 in the wild and no public exploit code.
Other vulnerabilities in fleetdm fleet
- CVE-2020-26276 SAML authentication vulnerability in Fleet
- CVE-2026-103264 Fleet before 4.87.0 Authentication Bypass via Device Identifiers
- CVE-2026-23518 Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment
- CVE-2026-26062 Fleet server may terminate unexpectedly when handling certain gRPC requests
- CVE-2026-26061 Fleet's unbounded request body read allows remote Denial of Service
Sources
Also known as GHSA-4r5r-ccr6-q6f6, GO-2026-4334.