# CVE-2026-23517: Fleet has an Access Control vulnerability in debug/pprof endpoints

> Low-privilege users can access debug endpoints to view sensitive server internals and trigger denial of service.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-4r5r-ccr6-q6f6, GO-2026-4334

## What is CVE-2026-23517?

CVE-2026-23517 is a medium-severity missing authorization vulnerability in fleetdm fleet, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Fleet is open source device management software. A broken access control issue in versions prior to 4.78.3, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 allowed authenticated users to access debug and profiling endpoints regardless of role. As a result, low-privilege users could view internal server diagnostics and trigger resource-intensive profiling operations. Fleet’s debug/pprof endpoints are accessible to any authenticated user regardless of role, including the lowest-privilege “Observer” role. This allows low-privilege users to access sensitive server internals, including runtime profiling data and in-memory application state, and to trigger CPU-intensive profiling operations that could lead to denial of service. Versions 4.78.3, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 fix the issue. If an immediate upgrade is not possible, users should put the debug/pprof endpoints behind an IP allowlist as a workaround.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-23517?

11 open source packages ship an affected version, including github.com/fleetdm/fleet and github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet` | Go | From 4.75.0 | 4.75.2 |
| `github.com/fleetdm/fleet` | Go | From 4.75.0 | 4.75.2 |
| `github.com/fleetdm/fleet` | Go | From 4.76.0 | 4.76.2 |
| `github.com/fleetdm/fleet` | Go | From 4.76.0 | 4.76.2 |
| `github.com/fleetdm/fleet` | Go | From 4.77.0 | 4.77.1 |
| `github.com/fleetdm/fleet` | Go | From 4.77.0 | 4.77.1 |
| `github.com/fleetdm/fleet` | Go | From 4.78.0 | 4.78.3 |
| `github.com/fleetdm/fleet` | Go | From 4.78.0 | 4.78.3 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.78.3-0.20260112221730-5c030e32a3a9 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.78.3-0.20260112221730-5c030e32a3a9 |
| `github.com/fleetdm/fleet/v4` | Go | From 4.75.0 | 4.75.2, 4.76.2, 4.77.1, 4.78.3 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-23517?

Upgrade github.com/fleetdm/fleet to a fixed version for your release line: 4.75.2, 4.76.2, 4.77.1 or 4.78.3.

## Is CVE-2026-23517 being exploited?

There is no known exploitation of CVE-2026-23517 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23517 and fix it if it is affected.

What it is: CVE-2026-23517 is a medium-severity missing authorization vulnerability in fleetdm fleet, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23517 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet (Go): affected from 4.75.0; fixed in 4.75.2
- github.com/fleetdm/fleet (Go): affected from 4.75.0; fixed in 4.75.2
- github.com/fleetdm/fleet (Go): affected from 4.76.0; fixed in 4.76.2
- github.com/fleetdm/fleet (Go): affected from 4.76.0; fixed in 4.76.2
- github.com/fleetdm/fleet (Go): affected from 4.77.0; fixed in 4.77.1
- github.com/fleetdm/fleet (Go): affected from 4.77.0; fixed in 4.77.1
- github.com/fleetdm/fleet (Go): affected from 4.78.0; fixed in 4.78.3
- github.com/fleetdm/fleet (Go): affected from 4.78.0; fixed in 4.78.3
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.78.3-0.20260112221730-5c030e32a3a9
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.78.3-0.20260112221730-5c030e32a3a9
- github.com/fleetdm/fleet/v4 (Go): affected from 4.75.0; fixed in 4.75.2, 4.76.2, 4.77.1, 4.78.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23517/ (Markdown: https://insights.sbomify.com/CVE-2026-23517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23517
- OSV: https://osv.dev/vulnerability/CVE-2026-23517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23517/
Summaries are generated and may contain mistakes; the official description above is the record.
