# CVE-2026-23524: Laravel Redis Horizontal Scaling Insecure Deserialization

> Attackers can achieve remote code execution via insecure deserialization in Laravel Reverb when horizontal scaling is enabled and Redis is accessible.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-m27r-m6rx-mhm4

## What is CVE-2026-23524?

CVE-2026-23524 is a critical unsafe deserialization vulnerability in laravel reverb, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Laravel Reverb provides a real-time WebSocket communication backend for Laravel applications. In versions 1.6.3 and below, Reverb passes data from the Redis channel directly into PHP’s unserialize() function without restricting which classes can be instantiated, which leaves users vulnerable to Remote Code Execution. The exploitability of this vulnerability is increased because Redis servers are commonly deployed without authentication, but only affects Laravel Reverb when horizontal scaling is enabled (REVERB_SCALING_ENABLED=true). This issue has been fixed in version 1.7.0. As a workaround, require a strong password for Redis access and ensure the service is only accessible via a private network or local loopback, and/or set REVERB_SCALING_ENABLED=false to bypass the vulnerable logic entirely (if the environment uses only one Reverb node).

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-23524?

2 open source packages ship an affected version, including laravel/reverb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/reverb` | Packagist | All versions | 1.7.0 |
| `laravel/reverb` | Packagist | All versions | 1.7.0 |

Products: Laravel Reverb.

## How do I fix CVE-2026-23524?

Upgrade laravel/reverb to 1.7.0 or later.

## Is CVE-2026-23524 being exploited?

There is no known exploitation of CVE-2026-23524 in the wild and no public exploit code.

Public exploit code:

- Laravel Reverb 为 Laravel 应用提供实时 WebSocket 通信后端。在 1.6.3 及更早版本中，Reverb 将来自 Redis 通道的数据直接传递给 PHP 的 unserialize() 函数，且未对可实例化的类进行限制，导致用户面临远程代码执行风险。 (github_poc): https://github.com/rockmelodies/CVE-2026-23524

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23524 and fix it if it is affected.

What it is: CVE-2026-23524 is a critical unsafe deserialization vulnerability in laravel reverb, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23524 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/reverb (Packagist): affected all versions; fixed in 1.7.0
- laravel/reverb (Packagist): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23524/ (Markdown: https://insights.sbomify.com/CVE-2026-23524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23524
- OSV: https://osv.dev/vulnerability/CVE-2026-23524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23524/
Summaries are generated and may contain mistakes; the official description above is the record.
