{"answers":{"affected":"3 open source packages ship an affected version, including wlc. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23535 in the wild and no public exploit code.","fix":"Upgrade wlc to 1.17.2 or later.","what":"CVE-2026-23535 is a high-severity path traversal vulnerability in WeblateOrg wlc, published on 16 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-23535 and fix it if it is affected.\n\nWhat it is: CVE-2026-23535 is a high-severity path traversal vulnerability in WeblateOrg wlc, published on 16 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-23535 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wlc (PyPI): affected all versions; fixed in 1.17.2\n- wlc (PyPI): affected all versions; fixed in 1.17.2\n- wlc (PyPI): affected all versions; fixed in 1.17.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23535/ (Markdown: https://insights.sbomify.com/CVE-2026-23535/index.md)","id":"CVE-2026-23535","markdown":"https://insights.sbomify.com/CVE-2026-23535/index.md","name":"CVE-2026-23535","record":{"aliases":["DEBIAN-CVE-2026-23535","GHSA-mmwx-79f6-67jg","PYSEC-2026-2053","UBUNTU-CVE-2026-23535"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Weblate CLI client","requires_auth":"low_privilege","summary":"A malicious Weblate server can force the wlc CLI to write files to arbitrary locations via unsanitized API slugs during downloads.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wlc","vendor":"weblate"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"wlc Path traversal: Unsanitized API slugs in download command","id":"CVE-2026-23535","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Feast: unauthenticated arbitrary file read","id":"CVE-2026-23536"},"packages":[{"ecosystem":"PyPI","fixed":["1.17.2"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":null,"source":"GHSA-mmwx-79f6-67jg"},{"ecosystem":"PyPI","fixed":["1.17.2"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":"pkg:pypi/wlc","source":"GHSA-mmwx-79f6-67jg"},{"ecosystem":"PyPI","fixed":["1.17.2"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":"pkg:pypi/wlc","source":"PYSEC-2026-2053"}],"prev":{"headline":"FreeRDP has heap-buffer-overflow in clear_decompress_bands_data","id":"CVE-2026-23534"},"products":["wlc"],"published":"2026-01-16","related":[{"cvss_score":5.3,"headline":"wlc may leak API keys due to an insecure API key configuration","id":"CVE-2026-22251","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":5.1,"headline":"wlc: print_html outputs API data without HTML escaping, enabling stored XSS","id":"CVE-2026-42150","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":2.5,"headline":"wlc can skip SSL verification","id":"CVE-2026-22250","kev_date_added":null,"published":"2026-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-16","vendors":["WeblateOrg"]},"summary":"A malicious Weblate server can force the wlc CLI to write files to arbitrary locations via unsanitized API slugs during downloads.","url":"https://insights.sbomify.com/CVE-2026-23535/"}