# CVE-2026-23535: wlc Path traversal: Unsanitized API slugs in download command

> A malicious Weblate server can force the wlc CLI to write files to arbitrary locations via unsanitized API slugs during downloads.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-23535, GHSA-mmwx-79f6-67jg, PYSEC-2026-2053, UBUNTU-CVE-2026-23535

## What is CVE-2026-23535?

CVE-2026-23535 is a high-severity path traversal vulnerability in WeblateOrg wlc, published on 16 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-23535?

3 open source packages ship an affected version, including wlc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wlc` | PyPI | All versions | 1.17.2 |
| `wlc` | PyPI | All versions | 1.17.2 |
| `wlc` | PyPI | All versions | 1.17.2 |

Products: Weblate Wlc.

## How do I fix CVE-2026-23535?

Upgrade wlc to 1.17.2 or later.

## Is CVE-2026-23535 being exploited?

There is no known exploitation of CVE-2026-23535 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg wlc

- [CVE-2026-22251](https://insights.sbomify.com/CVE-2026-22251/): wlc may leak API keys due to an insecure API key configuration (medium 5.3)
- [CVE-2026-42150](https://insights.sbomify.com/CVE-2026-42150/): wlc: print_html outputs API data without HTML escaping, enabling stored XSS (medium 5.1)
- [CVE-2026-22250](https://insights.sbomify.com/CVE-2026-22250/): wlc can skip SSL verification (low 2.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23535 and fix it if it is affected.

What it is: CVE-2026-23535 is a high-severity path traversal vulnerability in WeblateOrg wlc, published on 16 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23535 in the wild and no public exploit code.

Affected packages and fixed versions:
- wlc (PyPI): affected all versions; fixed in 1.17.2
- wlc (PyPI): affected all versions; fixed in 1.17.2
- wlc (PyPI): affected all versions; fixed in 1.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23535/ (Markdown: https://insights.sbomify.com/CVE-2026-23535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23535
- OSV: https://osv.dev/vulnerability/CVE-2026-23535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23535/
Summaries are generated and may contain mistakes; the official description above is the record.
