# CVE-2026-23552: Apache Camel: Camel-Keycloak: Cross-Realm Token Acceptance Bypass in KeycloakSecurityPolicy

> Attackers can bypass tenant isolation by using tokens from one Keycloak realm to access resources in another due to missing issuer validation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2026
- **Updated:** 23 Feb 2026
- **Also known as:** GHSA-c3f3-cc42-xr9v

## What is CVE-2026-23552?

CVE-2026-23552 is a critical authentication bypass vulnerability in Apache Camel, published on 23 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cross-Realm Token Acceptance Bypass in KeycloakSecurityPolicy Apache Camel Keycloak component. 

The Camel-Keycloak KeycloakSecurityPolicy does not validate the iss (issuer) claim of JWT tokens against the configured realm. A token issued by one Keycloak realm is silently accepted by a policy configured for a completely different realm, breaking tenant isolation.
This issue affects Apache Camel: from 4.15.0 before 4.18.0.

Users are recommended to upgrade to version 4.18.0, which fixes the issue.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-23552?

2 open source packages ship an affected version, including org.apache.camel:camel-keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-keycloak` | Maven | From 4.15.0 | 4.18.0 |
| `org.apache.camel:camel-keycloak` | Maven | From 4.15.0 | 4.18.0 |

Products: Apache Camel.

## How do I fix CVE-2026-23552?

Upgrade org.apache.camel:camel-keycloak to 4.18.0 or later.

## Is CVE-2026-23552 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23552 exists.

Public exploit code:

- CVE-2026-23552 - Cross-Realm Token Acceptance in camel-keycloak (github_poc): https://github.com/oscerd/CVE-2026-23552

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23552 and fix it if it is affected.

What it is: CVE-2026-23552 is a critical authentication bypass vulnerability in Apache Camel, published on 23 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23552 exists.

Affected packages and fixed versions:
- org.apache.camel:camel-keycloak (Maven): affected from 4.15.0; fixed in 4.18.0
- org.apache.camel:camel-keycloak (Maven): affected from 4.15.0; fixed in 4.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23552/ (Markdown: https://insights.sbomify.com/CVE-2026-23552/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23552
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23552
- OSV: https://osv.dev/vulnerability/CVE-2026-23552

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23552/
Summaries are generated and may contain mistakes; the official description above is the record.
