# CVE-2026-2359: Multer vulnerable to Denial of Service via resource exhaustion

> An attacker can cause resource exhaustion and denial of service by dropping connections during file uploads in the Multer Node.js middleware.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ECHO-2dc1-f89c-0ced, GHSA-v52c-386h-88mc, MINI-33q7-qv47-ww89, ROOT-APP-NPM-CVE-2026-2359

## What is CVE-2026-2359?

CVE-2026-2359 is a high-severity denial of service vulnerability in expressjs multer, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by dropping connection during file upload, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2026-2359?

2 open source packages ship an affected version, including multer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | All versions | 2.1.0 |
| `multer` | npm | All versions | 2.1.0 |

Products: Expressjs Multer.

## How do I fix CVE-2026-2359?

Upgrade multer to 2.1.0 or later.

## Is CVE-2026-2359 being exploited?

There is no known exploitation of CVE-2026-2359 in the wild and no public exploit code.

## Other vulnerabilities in expressjs multer

- [CVE-2026-3520](https://insights.sbomify.com/CVE-2026-3520/): Multer vulnerable to Denial of Service via uncontrolled recursion (high 8.7)
- [CVE-2026-3304](https://insights.sbomify.com/CVE-2026-3304/): Multer vulnerable to Denial of Service via incomplete cleanup (high 8.7)
- [CVE-2026-77037](https://insights.sbomify.com/CVE-2026-77037/): multer vulnerable to Denial of Service via file descriptor leak on aborted uploads (high 7.5)
- [CVE-2026-77078](https://insights.sbomify.com/CVE-2026-77078/): multer vulnerable to Denial of Service via crafted multipart field names (high 7.5)
- [CVE-2026-82333](https://insights.sbomify.com/CVE-2026-82333/): multer vulnerable to Denial of Service via oversized array index in field names (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2359 and fix it if it is affected.

What it is: CVE-2026-2359 is a high-severity denial of service vulnerability in expressjs multer, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2359 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected all versions; fixed in 2.1.0
- multer (npm): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2359/ (Markdown: https://insights.sbomify.com/CVE-2026-2359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2359
- OSV: https://osv.dev/vulnerability/CVE-2026-2359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2359/
Summaries are generated and may contain mistakes; the official description above is the record.
