CVE-2026-23630 Docmost is vulnerable to stored Cross-Site Scripting (XSS) through Mermaid rendering

Medium 6.3 Published Updated

Attackers can execute arbitrary JavaScript in victim browsers via malicious Mermaid diagrams in Docmost, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-23630?

CVE-2026-23630 is a medium-severity cross-site scripting vulnerability in docmost, published on 21 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Docmost is open-source collaborative wiki and documentation software. In versions 0.3.0 through 0.23.2, Mermaid code block rendering is vulnerable to stored Cross-Site Scripting (XSS). The frontend can render attacker-controlled Mermaid diagrams using mermaid.render(), then inject the returned SVG/HTML into the DOM via dangerouslySetInnerHTML without sanitization. Mermaid per-diagram %%{init}%% directives allow overriding securityLevel and enabling htmlLabels, permitting arbitrary HTML/JS execution for any viewer. This issue has been fixed in version 0.24.0.

Weakness: CWE-79, CWE-116

Which versions are affected by CVE-2026-23630?

It affects 1 product.

Products include Docmost Docmost.

How do I fix CVE-2026-23630?

No fix has been published for CVE-2026-23630 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-23630 being exploited?

There is no known exploitation of CVE-2026-23630 in the wild and no public exploit code.

Sources

Also known as GHSA-r4hj-mc62-jmwj.

Is CVE-2026-23630 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free