{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23630 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-23630 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-23630 is a medium-severity cross-site scripting vulnerability in docmost, published on 21 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-23630 and fix it if it is affected.\n\nWhat it is: CVE-2026-23630 is a medium-severity cross-site scripting vulnerability in docmost, published on 21 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-23630 in the wild and no public exploit code.\n\nAffected product: docmost. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23630/ (Markdown: https://insights.sbomify.com/CVE-2026-23630/index.md)","id":"CVE-2026-23630","markdown":"https://insights.sbomify.com/CVE-2026-23630/index.md","name":"CVE-2026-23630","record":{"aliases":["GHSA-r4hj-mc62-jmwj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Docmost wiki software","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript in victim browsers via malicious Mermaid diagrams in Docmost, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"docmost","vendor":"docmost"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Docmost is open-source collaborative wiki and documentation software. In versions 0.3.0 through 0.23.2, Mermaid code block rendering is vulnerable to stored Cross-Site Scripting (XSS). The frontend can render attacker-controlled Mermaid diagrams using mermaid.render(), then inject the returned SVG/HTML into the DOM via dangerouslySetInnerHTML without sanitization. Mermaid per-diagram %%{init}%% directives allow overriding securityLevel and enabling htmlLabels, permitting arbitrary HTML/JS execution for any viewer. This issue has been fixed in version 0.24.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Docmost is vulnerable to stored Cross-Site Scripting (XSS) through Mermaid rendering","id":"CVE-2026-23630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"redis-server Lua use-after-free may allow remote code execution","id":"CVE-2026-23631"},"packages":[],"prev":{"headline":"OpenEMR has SQL Injection in Immunization Search/Report","id":"CVE-2026-23627"},"products":["docmost"],"published":"2026-01-21","related":[{"cvss_score":7.3,"headline":"Docmost Affected by Stored XSS in Public Share Page","id":"CVE-2026-24045","kev_date_added":null,"published":"2026-02-10"},{"cvss_score":7.1,"headline":"Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip)","id":"CVE-2026-22249","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2025-55574","kev_date_added":null,"published":"2025-08-25"},{"cvss_score":5.4,"headline":"Docmost: XSS in Comments with JavaScript URI","id":"CVE-2026-40927","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":5.4,"headline":"Docmost page content has stored XSS via unsanitized attachment URLs","id":"CVE-2026-34212","kev_date_added":null,"published":"2026-04-14"},{"cvss_score":5.4,"headline":"Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation","id":"CVE-2026-34213","kev_date_added":null,"published":"2026-04-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["docmost"]},"summary":"Attackers can execute arbitrary JavaScript in victim browsers via malicious Mermaid diagrams in Docmost, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-23630/"}