CVE-2026-23632 Gogs user can update repository content with read-only permission
Attackers with read-only access can modify repository contents due to missing write permission checks in the content update endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23632?
CVE-2026-23632 is a medium-severity missing authorization vulnerability in gogs, published on 6 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, the endpoint "PUT /repos/:owner/:repo/contents/*" does not require write permissions and allows access with read permission only via repoAssignment(). After passing the permission check, PutContents() invokes UpdateRepoFile(), which results in commit creation and the execution of git push. As a result, a token with read-only permission can be used to modify repository contents. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Which versions are affected by CVE-2026-23632?
3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gogs.io/gogs Go | All versions | None |
gogs.io/gogs Go | All versions | 0.13.4 |
gogs.io/gogs Go | All versions | 0.13.4 |
Products include Gogs Gogs.
How do I fix CVE-2026-23632?
Upgrade gogs.io/gogs to 0.13.4 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-23632 being exploited?
There is no known exploitation of CVE-2026-23632 in the wild and no public exploit code.
Other vulnerabilities in gogs
Sources
Also known as GHSA-5qhx-gwfj-6jqr, GO-2026-4450.