# CVE-2026-23644: esm.sh has path traversal in `extractPackageTarball` that enables file writes from malicious packages

> Attackers can write arbitrary files via malicious packages due to path traversal in esm.sh, requiring a patch to prevent unauthorized file modifications.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-2657-3c98-63jq, GO-2026-4332

## What is CVE-2026-23644?

CVE-2026-23644 is a high-severity path traversal vulnerability in esm-dev esm.sh, published on 18 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

esm.sh is a no-build content delivery network (CDN) for web development. Prior to Go pseeudoversion 0.0.0-20260116051925-c62ab83c589e, the software has a path traversal vulnerability due to an incomplete fix. `path.Clean` normalizes a path but does not prevent absolute paths in a malicious tar file. Commit https://github.com/esm-dev/esm.sh/commit/9d77b88c320733ff6689d938d85d246a3af9af16, corresponding to pseudoversion 0.0.0-20260116051925-c62ab83c589e, fixes this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-23644?

5 open source packages ship an affected version, including github.com/esm-dev/esm.sh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/esm-dev/esm.sh` | Go | All versions | 0.0.0-20260116051925-c62ab83c589e |
| `github.com/esm-dev/esm.sh` | Go | All versions | 0.0.0-20260116051925-c62ab83c589e |
| `github.com/esm-dev/esm.sh` | Go | All versions | 0.0.0-20260116051925-c62ab83c589e |
| `github.com/esm-dev/esm.sh` | Go | From 0.0.1 to 136 | None |
| `github.com/esm-dev/esm.sh` | Go | From 0.0.1 to 136 | None |

Products: Esm Esm.sh.

## How do I fix CVE-2026-23644?

Upgrade github.com/esm-dev/esm.sh to 0.0.0-20260116051925-c62ab83c589e or later.

## Is CVE-2026-23644 being exploited?

There is no known exploitation of CVE-2026-23644 in the wild and no public exploit code.

## Other vulnerabilities in esm-dev esm.sh

- [CVE-2025-50180](https://insights.sbomify.com/CVE-2025-50180/): esm.sh is vulnerable to full-response SSRF (high 8.7)
- [CVE-2026-27730](https://insights.sbomify.com/CVE-2026-27730/): esm.sh has SSRF localhost/private-network bypass in `/http(s)` module route (high 8.6)
- [CVE-2025-65025](https://insights.sbomify.com/CVE-2025-65025/): esm.sh CDN service has arbitrary file write via tarslip (high 8.2)
- [CVE-2025-65026](https://insights.sbomify.com/CVE-2025-65026/): esm.sh CDN service has JS Template Literal Injection in CSS-to-JavaScript (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23644 and fix it if it is affected.

What it is: CVE-2026-23644 is a high-severity path traversal vulnerability in esm-dev esm.sh, published on 18 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23644 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/esm-dev/esm.sh (Go): affected all versions; fixed in 0.0.0-20260116051925-c62ab83c589e
- github.com/esm-dev/esm.sh (Go): affected all versions; fixed in 0.0.0-20260116051925-c62ab83c589e
- github.com/esm-dev/esm.sh (Go): affected all versions; fixed in 0.0.0-20260116051925-c62ab83c589e
- github.com/esm-dev/esm.sh (Go): affected from 0.0.1 up to 136; no fix listed
- github.com/esm-dev/esm.sh (Go): affected from 0.0.1 up to 136; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23644/ (Markdown: https://insights.sbomify.com/CVE-2026-23644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23644
- OSV: https://osv.dev/vulnerability/CVE-2026-23644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23644/
Summaries are generated and may contain mistakes; the official description above is the record.
