{"answers":{"affected":"1 open source package ship an affected version, including libusb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23679 exists.","fix":"Upgrade libusb to 1.0.30 or later.","what":"CVE-2026-23679 is a medium-severity vulnerability in libusb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23679 and fix it if it is affected.\n\nWhat it is: CVE-2026-23679 is a medium-severity vulnerability in libusb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23679 exists.\n\nAffected packages and fixed versions:\n- libusb (PyPI): affected all versions; fixed in 1.0.30\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23679/ (Markdown: https://insights.sbomify.com/CVE-2026-23679/index.md)","id":"CVE-2026-23679","markdown":"https://insights.sbomify.com/CVE-2026-23679/index.md","name":"CVE-2026-23679","record":{"aliases":["AZL-88412","AZL-88791","AZL-89153","BELL-CVE-2026-23679","DEBIAN-CVE-2026-23679","ECHO-9b94-4c06-2947","GHSA-jp69-qvgm-mqwx","JLSEC-2026-665","MINI-r3c8-9mg6-fxf5","OESA-2026-2742","OESA-2026-2743","PYSEC-2026-3978","SUSE-SU-2026:4050-1","SUSE-SU-2026:4080-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"USB library","requires_auth":"none","summary":"Attackers can crash applications using libusb by supplying malformed USB configuration descriptors that trigger a NULL pointer dereference.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"libusb","vendor":"libusb"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"libusb before version 1.0.30 contains a NULL pointer dereference vulnerability that allows attackers to crash applications by supplying a malformed USB configuration descriptor where an interface claims bNumEndpoints greater than zero but is followed by a class-specific descriptor whose bLength exceeds the remaining buffer size, causing parse_interface() to return early without allocating the endpoint array. Attackers can exploit this flaw through libusb_get_active_config_descriptor or libusb_get_config_descriptor by providing crafted descriptors via virtualized USB passthrough, file-based descriptor parsing, or network sources, causing any application iterating over endpoints to dereference a NULL endpoint pointer and crash.","ecosystems":["PyPI","SUSE:Linux Enterprise Micro 5.3","SUSE:Linux Enterprise Micro 5.4","SUSE:Linux Enterprise Micro 5.5","SUSE:Linux Enterprise Module for Basesystem 15 SP7","SUSE:Linux Enterprise Module for Package Hub 15 SP7","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"libusb \u003c 1.0.30 NULL Pointer Dereference in parse_interface()","id":"CVE-2026-23679","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"null_dereference","year":"2026"},"n_packages":7,"n_references":5,"next":{"headline":"Missing Authorization check in a function module in SAP Support Tools Plug-In","id":"CVE-2026-23681"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.30"],"introduced":["0"],"last_affected":[],"package":"libusb","purl":"pkg:pypi/libusb","source":"PYSEC-2026-3978"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.3","fixed":["1.0.24-150400.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libusb-1_0","purl":"pkg:rpm/suse/libusb-1_0\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.3","source":"SUSE-SU-2026:4050-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.4","fixed":["1.0.24-150400.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libusb-1_0","purl":"pkg:rpm/suse/libusb-1_0\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.4","source":"SUSE-SU-2026:4050-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.5","fixed":["1.0.24-150400.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libusb-1_0","purl":"pkg:rpm/suse/libusb-1_0\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.5","source":"SUSE-SU-2026:4050-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["1.0.24-150400.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libusb-1_0","purl":"pkg:rpm/suse/libusb-1_0\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:4050-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["1.0.24-150400.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libusb-1_0","purl":"pkg:rpm/suse/libusb-1_0\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2026:4050-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["1.0.20-7.3.1"],"introduced":["0"],"last_affected":[],"package":"libusb-1_0","purl":"pkg:rpm/suse/libusb-1_0\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:4080-1"}],"prev":{"headline":"Binardat 10G08-0800GSM Network Switch Traceroute CLI Command Injection","id":"CVE-2026-23678"},"products":["libusb"],"published":"2026-05-27","related":[{"cvss_score":5.1,"headline":"libusb \u003c 1.0.30 Out-of-Bounds Read in parse_iad_array()","id":"CVE-2026-47104","kev_date_added":null,"published":"2026-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["libusb"]},"summary":"Attackers can crash applications using libusb by supplying malformed USB configuration descriptors that trigger a NULL pointer dereference.","url":"https://insights.sbomify.com/CVE-2026-23679/"}