# CVE-2026-23679: libusb < 1.0.30 NULL Pointer Dereference in parse_interface()

> Attackers can crash applications using libusb by supplying malformed USB configuration descriptors that trigger a NULL pointer dereference.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 14 Jul 2026
- **Also known as:** AZL-88412, AZL-88791, AZL-89153, BELL-CVE-2026-23679, DEBIAN-CVE-2026-23679, ECHO-9b94-4c06-2947, GHSA-jp69-qvgm-mqwx, JLSEC-2026-665, MINI-r3c8-9mg6-fxf5, OESA-2026-2742, OESA-2026-2743, PYSEC-2026-3978, SUSE-SU-2026:4050-1, SUSE-SU-2026:4080-1

## What is CVE-2026-23679?

CVE-2026-23679 is a medium-severity vulnerability in libusb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libusb before version 1.0.30 contains a NULL pointer dereference vulnerability that allows attackers to crash applications by supplying a malformed USB configuration descriptor where an interface claims bNumEndpoints greater than zero but is followed by a class-specific descriptor whose bLength exceeds the remaining buffer size, causing parse_interface() to return early without allocating the endpoint array. Attackers can exploit this flaw through libusb_get_active_config_descriptor or libusb_get_config_descriptor by providing crafted descriptors via virtualized USB passthrough, file-based descriptor parsing, or network sources, causing any application iterating over endpoints to dereference a NULL endpoint pointer and crash.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-23679?

1 open source package ship an affected version, including libusb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libusb` | PyPI | All versions | 1.0.30 |
| `libusb-1_0` | SUSE:Linux Enterprise Micro 5.3 | All versions | 1.0.24-150400.3.6.1 |
| `libusb-1_0` | SUSE:Linux Enterprise Micro 5.4 | All versions | 1.0.24-150400.3.6.1 |
| `libusb-1_0` | SUSE:Linux Enterprise Micro 5.5 | All versions | 1.0.24-150400.3.6.1 |
| `libusb-1_0` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 1.0.24-150400.3.6.1 |
| `libusb-1_0` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 1.0.24-150400.3.6.1 |
| `libusb-1_0` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.0.20-7.3.1 |

Products: Libusb Libusb.

## How do I fix CVE-2026-23679?

Upgrade libusb to 1.0.30 or later.

## Is CVE-2026-23679 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23679 exists.

## Other vulnerabilities in libusb

- [CVE-2026-47104](https://insights.sbomify.com/CVE-2026-47104/): libusb < 1.0.30 Out-of-Bounds Read in parse_iad_array() (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23679 and fix it if it is affected.

What it is: CVE-2026-23679 is a medium-severity vulnerability in libusb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23679 exists.

Affected packages and fixed versions:
- libusb (PyPI): affected all versions; fixed in 1.0.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23679/ (Markdown: https://insights.sbomify.com/CVE-2026-23679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23679
- OSV: https://osv.dev/vulnerability/CVE-2026-23679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23679/
Summaries are generated and may contain mistakes; the official description above is the record.
