{"answers":{"affected":"8 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-classloader-api.","exploited":"There is no known exploitation of CVE-2026-23734 in the wild and no public exploit code.","fix":"Upgrade org.xwiki.commons:xwiki-commons-classloader-api to a fixed version for your release line: 17.4.9, 17.10.3, 18.1.0-rc-1 or 16.10.17.","what":"CVE-2026-23734 is a critical path traversal vulnerability in xwiki-commons, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23734 and fix it if it is affected.\n\nWhat it is: CVE-2026-23734 is a critical path traversal vulnerability in xwiki-commons, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23734 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.5.0; fixed in 17.10.3\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.5.0; fixed in 17.10.3\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 18.0.0-rc-1; fixed in 18.1.0-rc-1\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 18.0.0-rc-1; fixed in 18.1.0-rc-1\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 4.2-milestone-2; fixed in 16.10.17\n- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 4.2-milestone-2; fixed in 16.10.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23734/ (Markdown: https://insights.sbomify.com/CVE-2026-23734/index.md)","id":"CVE-2026-23734","markdown":"https://insights.sbomify.com/CVE-2026-23734/index.md","name":"CVE-2026-23734","record":{"aliases":["GHSA-xq3r-2qv5-vqqm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki Platform","requires_auth":"none","summary":"Attackers can read sensitive configuration files via path traversal in ssx and jsx endpoints, affecting XWiki Platform users.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"XWiki Platform is a generic wiki platform. Versions prior to 18.1.0-rc-1, 17.10.3, 17.4.9, and 16.10.17 allow access to read configuration files by using URLs such as http://localhost:8080/bin/ssx/Main/WebHome?resource=/../../WEB-INF/xwiki.cfg\u0026minify=false, leading to Path Traversal. The vulnerability is can be exploited via resources parameter the ssx and jsx endpoints by using leading slashes. This issue has been patched in 18.1.0-rc-1, 17.10.3, 17.4.9, 16.10.17.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XWiki Platform: Path traversal via resources parameter in ssx and jsx endpoints when using leading slash","id":"CVE-2026-23734","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') in graphql-modules","id":"CVE-2026-23735"},"packages":[{"ecosystem":"Maven","fixed":["17.4.9"],"introduced":["17.0.0-rc-1"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":null,"source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["17.4.9"],"introduced":["17.0.0-rc-1"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":"pkg:maven/org.xwiki.commons/xwiki-commons-classloader-api","source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["17.10.3"],"introduced":["17.5.0"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":null,"source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["17.10.3"],"introduced":["17.5.0"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":"pkg:maven/org.xwiki.commons/xwiki-commons-classloader-api","source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["18.1.0-rc-1"],"introduced":["18.0.0-rc-1"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":null,"source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["18.1.0-rc-1"],"introduced":["18.0.0-rc-1"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":"pkg:maven/org.xwiki.commons/xwiki-commons-classloader-api","source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["16.10.17"],"introduced":["4.2-milestone-2"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":null,"source":"GHSA-xq3r-2qv5-vqqm"},{"ecosystem":"Maven","fixed":["16.10.17"],"introduced":["4.2-milestone-2"],"last_affected":[],"package":"org.xwiki.commons:xwiki-commons-classloader-api","purl":"pkg:maven/org.xwiki.commons/xwiki-commons-classloader-api","source":"GHSA-xq3r-2qv5-vqqm"}],"prev":{"headline":"Lobe Chat has Cross-Site Scripting (XSS) issue that may escalate to Remote Code Execution (RCE)","id":"CVE-2026-23733"},"products":["xwiki-commons"],"published":"2026-05-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-26","vendors":["xwiki"]},"summary":"Attackers can read sensitive configuration files via path traversal in ssx and jsx endpoints, affecting XWiki Platform users.","url":"https://insights.sbomify.com/CVE-2026-23734/"}