# CVE-2026-23734: XWiki Platform: Path traversal via resources parameter in ssx and jsx endpoints when using leading slash

> Attackers can read sensitive configuration files via path traversal in ssx and jsx endpoints, affecting XWiki Platform users.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-xq3r-2qv5-vqqm

## What is CVE-2026-23734?

CVE-2026-23734 is a critical path traversal vulnerability in xwiki-commons, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Versions prior to 18.1.0-rc-1, 17.10.3, 17.4.9, and 16.10.17 allow access to read configuration files by using URLs such as http://localhost:8080/bin/ssx/Main/WebHome?resource=/../../WEB-INF/xwiki.cfg&minify=false, leading to Path Traversal. The vulnerability is can be exploited via resources parameter the ssx and jsx endpoints by using leading slashes. This issue has been patched in 18.1.0-rc-1, 17.10.3, 17.4.9, 16.10.17.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-23734?

8 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-classloader-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 17.0.0-rc-1 | 17.4.9 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 17.0.0-rc-1 | 17.4.9 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 17.5.0 | 17.10.3 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 17.5.0 | 17.10.3 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 18.0.0-rc-1 | 18.1.0-rc-1 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 18.0.0-rc-1 | 18.1.0-rc-1 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 4.2-milestone-2 | 16.10.17 |
| `org.xwiki.commons:xwiki-commons-classloader-api` | Maven | From 4.2-milestone-2 | 16.10.17 |

## How do I fix CVE-2026-23734?

Upgrade org.xwiki.commons:xwiki-commons-classloader-api to a fixed version for your release line: 17.4.9, 17.10.3, 18.1.0-rc-1 or 16.10.17.

## Is CVE-2026-23734 being exploited?

There is no known exploitation of CVE-2026-23734 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23734 and fix it if it is affected.

What it is: CVE-2026-23734 is a critical path traversal vulnerability in xwiki-commons, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23734 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.5.0; fixed in 17.10.3
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 17.5.0; fixed in 17.10.3
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 18.0.0-rc-1; fixed in 18.1.0-rc-1
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 18.0.0-rc-1; fixed in 18.1.0-rc-1
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 4.2-milestone-2; fixed in 16.10.17
- org.xwiki.commons:xwiki-commons-classloader-api (Maven): affected from 4.2-milestone-2; fixed in 16.10.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23734/ (Markdown: https://insights.sbomify.com/CVE-2026-23734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23734
- OSV: https://osv.dev/vulnerability/CVE-2026-23734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23734/
Summaries are generated and may contain mistakes; the official description above is the record.
