CVE-2026-23735 Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') in graphql-modules
Attackers can exploit a race condition to mix request contexts, potentially leaking authentication tokens or accessing unauthorized data in GraphQL services.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23735?
CVE-2026-23735 is a high-severity vulnerability in graphql-hive graphql-modules, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
GraphQL Modules is a toolset of libraries and guidelines dedicated to create reusable, maintainable, testable and extendable modules out of your GraphQL server. From 2.2.1 to before 2.4.1 and 3.1.1, when 2 or more parallel requests are made which trigger the same service, the context of the requests is mixed up in the service when the context is injected via @ExecutionContext(). ExecutionContext is often used to pass authentication tokens from incoming requests to services loading data from backend APIs. This vulnerability is fixed in 2.4.1 and 3.1.1.
Weakness: CWE-362
Which versions are affected by CVE-2026-23735?
4 open source packages ship an affected version, including graphql-modules.
| Package | Affected | Fixed in |
|---|---|---|
graphql-modules npm | From 2.2.1 | 2.4.1 |
graphql-modules npm | From 2.2.1 | 2.4.1 |
graphql-modules npm | From 3.0.0 | 3.1.1 |
graphql-modules npm | From 3.0.0 | 3.1.1 |
How do I fix CVE-2026-23735?
Upgrade graphql-modules to a fixed version for your release line: 2.4.1 or 3.1.1.
Is CVE-2026-23735 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23735 exists.
Sources
Also known as GHSA-53wg-r69p-v3r7.