{"answers":{"affected":"4 open source packages ship an affected version, including graphql-modules.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23735 exists.","fix":"Upgrade graphql-modules to a fixed version for your release line: 2.4.1 or 3.1.1.","what":"CVE-2026-23735 is a high-severity vulnerability in graphql-hive graphql-modules, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23735 and fix it if it is affected.\n\nWhat it is: CVE-2026-23735 is a high-severity vulnerability in graphql-hive graphql-modules, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23735 exists.\n\nAffected packages and fixed versions:\n- graphql-modules (npm): affected from 2.2.1; fixed in 2.4.1\n- graphql-modules (npm): affected from 2.2.1; fixed in 2.4.1\n- graphql-modules (npm): affected from 3.0.0; fixed in 3.1.1\n- graphql-modules (npm): affected from 3.0.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23735/ (Markdown: https://insights.sbomify.com/CVE-2026-23735/index.md)","id":"CVE-2026-23735","markdown":"https://insights.sbomify.com/CVE-2026-23735/index.md","name":"CVE-2026-23735","record":{"aliases":["GHSA-53wg-r69p-v3r7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL server library","requires_auth":"none","summary":"Attackers can exploit a race condition to mix request contexts, potentially leaking authentication tokens or accessing unauthorized data in GraphQL services.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"GraphQL Modules is a toolset of libraries and guidelines dedicated to create reusable, maintainable, testable and extendable modules out of your GraphQL server. From 2.2.1 to before 2.4.1 and 3.1.1, when 2 or more parallel requests are made which trigger the same service, the context of the requests is mixed up in the service when the context is injected via @ExecutionContext(). ExecutionContext is often used to pass authentication tokens from incoming requests to services loading data from backend APIs. This vulnerability is fixed in 2.4.1 and 3.1.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') in graphql-modules","id":"CVE-2026-23735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"race_condition","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"seroval Affected by Prototype Pollution via JSON Deserialization","id":"CVE-2026-23736"},"packages":[{"ecosystem":"npm","fixed":["2.4.1"],"introduced":["2.2.1"],"last_affected":[],"package":"graphql-modules","purl":null,"source":"GHSA-53wg-r69p-v3r7"},{"ecosystem":"npm","fixed":["2.4.1"],"introduced":["2.2.1"],"last_affected":[],"package":"graphql-modules","purl":"pkg:npm/graphql-modules","source":"GHSA-53wg-r69p-v3r7"},{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["3.0.0"],"last_affected":[],"package":"graphql-modules","purl":null,"source":"GHSA-53wg-r69p-v3r7"},{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["3.0.0"],"last_affected":[],"package":"graphql-modules","purl":"pkg:npm/graphql-modules","source":"GHSA-53wg-r69p-v3r7"}],"prev":{"headline":"XWiki Platform: Path traversal via resources parameter in ssx and jsx endpoints when using leading slash","id":"CVE-2026-23734"},"products":["graphql-modules"],"published":"2026-01-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-16","vendors":["graphql-hive"]},"summary":"Attackers can exploit a race condition to mix request contexts, potentially leaking authentication tokens or accessing unauthorized data in GraphQL services.","url":"https://insights.sbomify.com/CVE-2026-23735/"}