# CVE-2026-23738: Cross-site scripting in asterisk

> Attackers can inject malicious scripts into the Asterisk web server status page via unsanitized cookies or query parameters, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-23738, GHSA-v6hp-wh3r-cwxh, UBUNTU-CVE-2026-23738

## What is CVE-2026-23738?

CVE-2026-23738 is a low-severity cross-site scripting vulnerability in asterisk, published on 6 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to versions 20.7-cert9, 20.18.2, 21.12.1, 22.8.2, and 23.2.2, user supplied/control values for Cookies and any GET variable query Parameter are directly interpolated into the HTML of the page using ast_str_append. The endpoint at GET /httpstatus is the potential vulnerable endpoint relating to asterisk/main /http.c. This issue has been patched in versions 20.7-cert9, 20.18.2, 21.12.1, 22.8.2, and 23.2.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-23738?

It affects 2 products.


Products: Sangoma Asterisk, Sangoma Certified Asterisk.

## How do I fix CVE-2026-23738?

Upgrade to a fixed version.

## Is CVE-2026-23738 being exploited?

There is no known exploitation of CVE-2026-23738 in the wild and no public exploit code.

## Other vulnerabilities in asterisk

- [CVE-2024-57520](https://insights.sbomify.com/CVE-2024-57520/): Path traversal in n/a (critical 9.8)
- [CVE-2025-47779](https://insights.sbomify.com/CVE-2025-47779/): Using malformed From header can forge identity with ";" or NULL in name portion (high 7.7)
- [CVE-2025-57767](https://insights.sbomify.com/CVE-2025-57767/): Asterisk can crash from a specifically malformed Authorization header in an incoming SIP request (high 7.5)
- [CVE-2022-37325](https://insights.sbomify.com/CVE-2022-37325/): Memory corruption in n/a (high 7.5)
- [CVE-2025-1131](https://insights.sbomify.com/CVE-2025-1131/): Asterisk Unsafe Shell Sourcing in safe_asterisk Leads to Local Privilege Escalation (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23738 and fix it if it is affected.

What it is: CVE-2026-23738 is a low-severity cross-site scripting vulnerability in asterisk, published on 6 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23738 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23738/ (Markdown: https://insights.sbomify.com/CVE-2026-23738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23738
- OSV: https://osv.dev/vulnerability/CVE-2026-23738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23738/
Summaries are generated and may contain mistakes; the official description above is the record.
