# CVE-2026-23739: Asterisk xml.c uses unsafe XML_PARSE_NOENT leading to potential XXE Injection

> Attackers can exploit unsafe XML parsing in Asterisk to disclose sensitive local files via XXE or XInclude attacks.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-23739, GHSA-85x7-54wr-vh42, UBUNTU-CVE-2026-23739

## What is CVE-2026-23739?

CVE-2026-23739 is a low-severity vulnerability in asterisk, published on 6 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to versions 20.7-cert9, 20.18.2, 21.12.1, 22.8.2, and 23.2.2, the ast_xml_open() function in xml.c parses XML documents using libxml with unsafe parsing options that enable entity expansion and XInclude processing. Specifically, it invokes xmlReadFile() with the XML_PARSE_NOENT flag and later processes XIncludes via xmlXIncludeProcess().If any untrusted or user-supplied XML file is passed to this function, it can allow an attacker to trigger XML External Entity (XXE) or XInclude-based local file disclosure, potentially exposing sensitive files from the host system. This can also be triggered in other cases in which the user is able to supply input in xml format that triggers the asterisk process to parse it. This issue has been patched in versions 20.7-cert9, 20.18.2, 21.12.1, 22.8.2, and 23.2.2.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-23739?

It affects 2 products.


Products: Sangoma Asterisk, Sangoma Certified Asterisk.

## How do I fix CVE-2026-23739?

Upgrade to a fixed version.

## Is CVE-2026-23739 being exploited?

There is no known exploitation of CVE-2026-23739 in the wild and no public exploit code.

## Other vulnerabilities in asterisk

- [CVE-2024-57520](https://insights.sbomify.com/CVE-2024-57520/): Path traversal in n/a (critical 9.8)
- [CVE-2025-47779](https://insights.sbomify.com/CVE-2025-47779/): Using malformed From header can forge identity with ";" or NULL in name portion (high 7.7)
- [CVE-2025-57767](https://insights.sbomify.com/CVE-2025-57767/): Asterisk can crash from a specifically malformed Authorization header in an incoming SIP request (high 7.5)
- [CVE-2022-37325](https://insights.sbomify.com/CVE-2022-37325/): Memory corruption in n/a (high 7.5)
- [CVE-2025-1131](https://insights.sbomify.com/CVE-2025-1131/): Asterisk Unsafe Shell Sourcing in safe_asterisk Leads to Local Privilege Escalation (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23739 and fix it if it is affected.

What it is: CVE-2026-23739 is a low-severity vulnerability in asterisk, published on 6 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23739 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23739/ (Markdown: https://insights.sbomify.com/CVE-2026-23739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23739
- OSV: https://osv.dev/vulnerability/CVE-2026-23739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23739/
Summaries are generated and may contain mistakes; the official description above is the record.
