CVE-2026-23740 Asterisk vulnerable to potential privilege escalation

None 0.0 Published Updated

An attacker can escalate privileges to root by exploiting world-writable directories used by Asterisk's coredumper for gdb files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-23740?

CVE-2026-23740 is a vulnerability in asterisk, published on 6 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to versions 20.7-cert9, 20.18.2, 21.12.1, 22.8.2, and 23.2.2, when ast_coredumper writes its gdb init and output files to a directory that is world-writable (for example /tmp), an attacker with write permission(which is all users on a linux system) to that directory can cause root to execute arbitrary commands or overwrite arbitrary files by controlling the gdb init file and output paths. This issue has been patched in versions 20.7-cert9, 20.18.2, 21.12.1, 22.8.2, and 23.2.2.

Weakness: CWE-427

Which versions are affected by CVE-2026-23740?

It affects 2 products.

Products include Sangoma Asterisk, Sangoma Certified Asterisk.

How do I fix CVE-2026-23740?

Apply the vendor's patch.

Is CVE-2026-23740 being exploited?

There is no known exploitation of CVE-2026-23740 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-23740, GHSA-xpc6-x892-v83c, UBUNTU-CVE-2026-23740.

Is CVE-2026-23740 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free