CVE-2026-23743 Discourse allows permalinks to restricted resources to leak resource slugs to unauthorized users
Unauthorized users can leak sensitive resource slugs from private topics via permalinks, exposing private titles in redirect headers and error pages.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23743?
CVE-2026-23743 is a medium-severity vulnerability in Discourse Discourse, published on 28 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, permalinks pointing to access-restricted resources (private topics, categories, posts, or hidden tags) were redirecting users to URLs containing the resource slug, even when the user didn't have access to view the resource. This leaked potentially sensitive information (e.g., private topic titles) via the redirect Location header and the 404 page's search box. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.
Weakness: CWE-200
Which versions are affected by CVE-2026-23743?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 3.5.4, 2025.11.2, 2026.2.0 |
Products include Discourse Discourse.
How do I fix CVE-2026-23743?
Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2 or 2026.2.0.
Is CVE-2026-23743 being exploited?
There is no known exploitation of CVE-2026-23743 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-23743, GHSA-v5jw-rxc6-4cvv.