# CVE-2026-23744: REC in MCPJam inspector due to HTTP Endpoint exposes

> An attacker can achieve remote code execution by sending a crafted HTTP request to the MCPJam inspector, which lacks authentication on its default network interface.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** GHSA-232v-j27c-5pp6

## What is CVE-2026-23744?

CVE-2026-23744 is a critical missing authorization vulnerability in MCPJam inspector, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MCPJam inspector is the local-first development platform for MCP servers. Versions 1.4.2 and earlier are vulnerable to remote code execution (RCE) vulnerability, which allows an attacker to send a crafted HTTP request that triggers the installation of an MCP server, leading to RCE. Since MCPJam inspector by default listens on 0.0.0.0 instead of 127.0.0.1, an attacker can trigger the RCE remotely via a simple HTTP request. Version 1.4.3 contains a patch.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-23744?

2 open source packages ship an affected version, including @mcpjam/inspector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@mcpjam/inspector` | npm | All versions | 1.4.3 |
| `@mcpjam/inspector` | npm | All versions | 1.4.3 |

Products: Mcpjam Inspector.

## How do I fix CVE-2026-23744?

Upgrade @mcpjam/inspector to 1.4.3 or later.

## Is CVE-2026-23744 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23744 exists.

Public exploit code:

- CVE-2026-23744 - Versions 1.4.2 and earlier of MCPJam inspector are vulnerable to remote code execution (RCE). Because the tool listens on 0.0.0.0 by default, an attacker can trigger the installation and execution of a malicious MCP server by sending a crafted HTTP request. Version 1.4.3 contains a patch for this issue. (github_poc): https://github.com/boroeurnprach/CVE-2026-23744-PoC
- MCPJam inspector contains a remote code execution (github_poc): https://github.com/suljov/CVE-2026-23744-Remote-Code-Execution-POC
- A proof-of-concept exploit for CVE-2026-23744 - MCPJam Inspector Remote Code Execution (RCE) vulnerability. This tool demonstrates the security flaw in versions <=1.4.2 and helps security researchers verify patches. For authorized testing and educational purposes only. Includes multiple payload options, command execution, and session management. (github_poc): https://github.com/CerberusMrXi/CVE-2026-23744-MCPJam-Exploit
- CVE-2026-23744 - MCPJam inspector Remote-Code-Execution: Proof Of Concept (POC (github_poc): https://github.com/FrenzisRed/CVE-2026-23744
- MCPJam Inspector is a local-first development platform for MCP servers. In versions 1.4.2 (and earlier), a RCE flaw lets attackers send crafted HTTP request that installs an MCP server and runs code remotely, because the service listens on 0.0.0.0 (instead of 127.0.0.1) by default. (github_poc): https://github.com/luiskrnr/exploit-CVE-2026-23744
- CVE-2026-23744 is an unauthenticated command injection in MCPJam Inspector ≤1.4.2 via /api/mcp/connect. This POC exploits it by sending a crafted JSON payload to execute arbitrary commands, granting a reverse shell with PTY. (github_poc): https://github.com/Mluex0/CVE-2026-23744-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23744 and fix it if it is affected.

What it is: CVE-2026-23744 is a critical missing authorization vulnerability in MCPJam inspector, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23744 exists.

Affected packages and fixed versions:
- @mcpjam/inspector (npm): affected all versions; fixed in 1.4.3
- @mcpjam/inspector (npm): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23744/ (Markdown: https://insights.sbomify.com/CVE-2026-23744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23744
- OSV: https://osv.dev/vulnerability/CVE-2026-23744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23744/
Summaries are generated and may contain mistakes; the official description above is the record.
