CVE-2026-23794 Apache Syncope: Reflected XSS on Enduser Login
Reflected XSS in Apache Syncope allows attackers to steal user credentials via malicious links, requiring an upgrade to secure the login page.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-23794?
CVE-2026-23794 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials.
This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3.
Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-23794?
4 open source packages ship an affected version, including org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui Maven | From 3.0.0 | 3.0.16 |
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui Maven | From 3.0.0 | 3.0.16 |
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui Maven | From 4.0.0 | 4.0.4 |
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui Maven | From 4.0.0 | 4.0.4 |
Products include Apache Syncope.
How do I fix CVE-2026-23794?
Upgrade org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui to a fixed version for your release line: 3.0.16 or 4.0.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-23794 being exploited?
There is no known exploitation of CVE-2026-23794 in the wild and no public exploit code.
Other vulnerabilities in Apache Syncope
- CVE-2026-53405 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask
- CVE-2026-53421 Apache Syncope: Remote Code Execution via Scripted Connector
- CVE-2026-57308 Apache Syncope: SQL injection vulnerability in Audit Events search
- CVE-2026-62183 Apache Syncope: User self-service privilege escalation
- CVE-2026-63071 Apache Syncope: RCE via Groovy Sandbox bypass
Sources
Also known as GHSA-v84m-gfw5-hm2w.