{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23794 in the wild and no public exploit code.","fix":"Upgrade org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui to a fixed version for your release line: 3.0.16 or 4.0.4.","what":"CVE-2026-23794 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-23794 and fix it if it is affected.\n\nWhat it is: CVE-2026-23794 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-23794 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 3.0.0; fixed in 3.0.16\n- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 3.0.0; fixed in 3.0.16\n- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 4.0.0; fixed in 4.0.4\n- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 4.0.0; fixed in 4.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23794/ (Markdown: https://insights.sbomify.com/CVE-2026-23794/index.md)","id":"CVE-2026-23794","markdown":"https://insights.sbomify.com/CVE-2026-23794/index.md","name":"CVE-2026-23794","record":{"aliases":["GHSA-v84m-gfw5-hm2w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Syncope","requires_auth":"low_privilege","summary":"Reflected XSS in Apache Syncope allows attackers to steal user credentials via malicious links, requiring an upgrade to secure the login page.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"syncope","vendor":"apache"}],"cvss":{"score":6.8,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Reflected XSS in Apache Syncope's Enduser Login page.\nAn attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials.\n\nThis issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3.\n\nUsers are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Syncope: Reflected XSS on Enduser Login","id":"CVE-2026-23794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Apache Syncope: Console XXE on Keymaster parameters","id":"CVE-2026-23795"},"packages":[{"ecosystem":"Maven","fixed":["3.0.16"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui","purl":null,"source":"GHSA-v84m-gfw5-hm2w"},{"ecosystem":"Maven","fixed":["3.0.16"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui","purl":"pkg:maven/org.apache.syncope.client.idrepo/syncope-client-idrepo-common-ui","source":"GHSA-v84m-gfw5-hm2w"},{"ecosystem":"Maven","fixed":["4.0.4"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui","purl":null,"source":"GHSA-v84m-gfw5-hm2w"},{"ecosystem":"Maven","fixed":["4.0.4"],"introduced":["4.0.0"],"last_affected":[],"package":"org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui","purl":"pkg:maven/org.apache.syncope.client.idrepo/syncope-client-idrepo-common-ui","source":"GHSA-v84m-gfw5-hm2w"}],"prev":{"headline":"Memory corruption in Exynos 1330 firmware","id":"CVE-2026-23793"},"products":["Apache Syncope"],"published":"2026-02-03","related":[{"cvss_score":9.8,"headline":"Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask","id":"CVE-2026-53405","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: Remote Code Execution via Scripted Connector","id":"CVE-2026-53421","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: SQL injection vulnerability in Audit Events search","id":"CVE-2026-57308","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: User self-service privilege escalation","id":"CVE-2026-62183","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: RCE via Groovy Sandbox bypass","id":"CVE-2026-63071","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Expression Language Injection in Apache Syncope","id":"CVE-2020-1959","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":9.8,"headline":"Injection in Apache Syncope","id":"CVE-2020-1961","kev_date_added":null,"published":"2020-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-03","vendors":["Apache Software Foundation"]},"summary":"Reflected XSS in Apache Syncope allows attackers to steal user credentials via malicious links, requiring an upgrade to secure the login page.","url":"https://insights.sbomify.com/CVE-2026-23794/"}