# CVE-2026-23794: Apache Syncope: Reflected XSS on Enduser Login

> Reflected XSS in Apache Syncope allows attackers to steal user credentials via malicious links, requiring an upgrade to secure the login page.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 3 Feb 2026
- **Also known as:** GHSA-v84m-gfw5-hm2w

## What is CVE-2026-23794?

CVE-2026-23794 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Reflected XSS in Apache Syncope's Enduser Login page.
An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials.

This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3.

Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-23794?

4 open source packages ship an affected version, including org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui` | Maven | From 3.0.0 | 3.0.16 |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui` | Maven | From 3.0.0 | 3.0.16 |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui` | Maven | From 4.0.0 | 4.0.4 |

Products: Apache Syncope.

## How do I fix CVE-2026-23794?

Upgrade org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui to a fixed version for your release line: 3.0.16 or 4.0.4.

## Is CVE-2026-23794 being exploited?

There is no known exploitation of CVE-2026-23794 in the wild and no public exploit code.

## Other vulnerabilities in Apache Syncope

- [CVE-2026-53405](https://insights.sbomify.com/CVE-2026-53405/): Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask (critical 9.8)
- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23794 and fix it if it is affected.

What it is: CVE-2026-23794 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23794 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 3.0.0; fixed in 3.0.16
- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 3.0.0; fixed in 3.0.16
- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui (Maven): affected from 4.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23794/ (Markdown: https://insights.sbomify.com/CVE-2026-23794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23794
- OSV: https://osv.dev/vulnerability/CVE-2026-23794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23794/
Summaries are generated and may contain mistakes; the official description above is the record.
