CVE-2026-23795 Apache Syncope: Console XXE on Keymaster parameters
An administrator can exploit an XXE vulnerability in Apache Syncope Console Keymaster parameters to leak sensitive data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23795?
CVE-2026-23795 is a medium-severity vulnerability in Apache Syncope, published on 3 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper Restriction of XML External Entity Reference vulnerability in Apache Syncope Console. An administrator with adequate entitlements to create or edit Keymaster parameters via Console can construct malicious XML text to launch an XXE attack, thereby causing sensitive data leakage occurs.
This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3.
Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
Weakness: CWE-611
Which versions are affected by CVE-2026-23795?
4 open source packages ship an affected version, including org.apache.syncope.client.idrepo:syncope-client-idrepo-console. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.syncope.client.idrepo:syncope-client-idrepo-console Maven | From 3.0.0 | 3.0.16 |
org.apache.syncope.client.idrepo:syncope-client-idrepo-console Maven | From 3.0.0 | 3.0.16 |
org.apache.syncope.client.idrepo:syncope-client-idrepo-console Maven | From 4.0.0 | 4.0.4 |
org.apache.syncope.client.idrepo:syncope-client-idrepo-console Maven | From 4.0.0 | 4.0.4 |
Products include Apache Syncope.
How do I fix CVE-2026-23795?
Upgrade org.apache.syncope.client.idrepo:syncope-client-idrepo-console to a fixed version for your release line: 3.0.16 or 4.0.4.
Is CVE-2026-23795 being exploited?
There is no known exploitation of CVE-2026-23795 in the wild and no public exploit code.
Other vulnerabilities in Apache Syncope
- CVE-2026-53405 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask
- CVE-2026-53421 Apache Syncope: Remote Code Execution via Scripted Connector
- CVE-2026-57308 Apache Syncope: SQL injection vulnerability in Audit Events search
- CVE-2026-62183 Apache Syncope: User self-service privilege escalation
- CVE-2026-63071 Apache Syncope: RCE via Groovy Sandbox bypass
Sources
Also known as GHSA-73f3-rqqf-2j54.