# CVE-2026-23795: Apache Syncope: Console XXE on Keymaster parameters

> An administrator can exploit an XXE vulnerability in Apache Syncope Console Keymaster parameters to leak sensitive data.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 3 Feb 2026
- **Also known as:** GHSA-73f3-rqqf-2j54

## What is CVE-2026-23795?

CVE-2026-23795 is a medium-severity vulnerability in Apache Syncope, published on 3 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Restriction of XML External Entity Reference vulnerability in Apache Syncope Console.
An administrator with adequate entitlements to create or edit Keymaster parameters via Console can construct malicious XML text to launch an XXE attack, thereby causing sensitive data leakage occurs.

This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3.

Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-23795?

4 open source packages ship an affected version, including org.apache.syncope.client.idrepo:syncope-client-idrepo-console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-console` | Maven | From 3.0.0 | 3.0.16 |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-console` | Maven | From 3.0.0 | 3.0.16 |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-console` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.syncope.client.idrepo:syncope-client-idrepo-console` | Maven | From 4.0.0 | 4.0.4 |

Products: Apache Syncope.

## How do I fix CVE-2026-23795?

Upgrade org.apache.syncope.client.idrepo:syncope-client-idrepo-console to a fixed version for your release line: 3.0.16 or 4.0.4.

## Is CVE-2026-23795 being exploited?

There is no known exploitation of CVE-2026-23795 in the wild and no public exploit code.

## Other vulnerabilities in Apache Syncope

- [CVE-2026-53405](https://insights.sbomify.com/CVE-2026-53405/): Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask (critical 9.8)
- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23795 and fix it if it is affected.

What it is: CVE-2026-23795 is a medium-severity vulnerability in Apache Syncope, published on 3 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23795 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.syncope.client.idrepo:syncope-client-idrepo-console (Maven): affected from 3.0.0; fixed in 3.0.16
- org.apache.syncope.client.idrepo:syncope-client-idrepo-console (Maven): affected from 3.0.0; fixed in 3.0.16
- org.apache.syncope.client.idrepo:syncope-client-idrepo-console (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.syncope.client.idrepo:syncope-client-idrepo-console (Maven): affected from 4.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23795/ (Markdown: https://insights.sbomify.com/CVE-2026-23795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23795
- OSV: https://osv.dev/vulnerability/CVE-2026-23795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23795/
Summaries are generated and may contain mistakes; the official description above is the record.
