CVE-2026-23833 ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component
An integer overflow in ESPHome's API decoder allows remote attackers to crash devices via malformed packets when encryption is disabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23833?
CVE-2026-23833 is a low-severity vulnerability in esphome, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ESPHome is a system to control microcontrollers remotely through Home Automation systems. In versions 2025.9.0 through 2025.12.6, an integer overflow in the API component's protobuf decoder allows denial-of-service attacks when API encryption is not used. The bounds check `ptr + field_length > end` in `components/api/proto.cpp` can overflow when a malicious client sends a large `field_length` value. This affects all ESPHome device platforms (ESP32, ESP8266, RP2040, LibreTiny). The overflow bypasses the out-of-bounds check, causing the device to read invalid memory and crash. When using the plaintext API protocol, this attack can be performed without authentication. When noise encryption is enabled, knowledge of the encryption key is required. Users should upgrade to ESPHome 2025.12.7 or later to receive a patch, enable API encryption with a unique key per device, and follow the Security Best Practices.
Weakness: CWE-190
Which versions are affected by CVE-2026-23833?
3 open source packages ship an affected version, including esphome. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
esphome PyPI | From 2025.9.0 | 2025.12.7 |
esphome PyPI | From 2025.9.0 | 2025.12.7 |
esphome PyPI | From 2025.9.0 | 2025.12.7 |
Products include Esphome Esphome.
How do I fix CVE-2026-23833?
Upgrade esphome to 2025.12.7 or later.
Is CVE-2026-23833 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23833 exists.
Other vulnerabilities in esphome
Sources
Also known as GHSA-4h3h-63v6-88qx, PYSEC-2026-1326.