# CVE-2026-23833: ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component

> An integer overflow in ESPHome's API decoder allows remote attackers to crash devices via malformed packets when encryption is disabled.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-4h3h-63v6-88qx, PYSEC-2026-1326

## What is CVE-2026-23833?

CVE-2026-23833 is a low-severity vulnerability in esphome, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ESPHome is a system to control microcontrollers remotely through Home Automation systems. In versions 2025.9.0 through 2025.12.6, an integer overflow in the API component's protobuf decoder allows denial-of-service attacks when API encryption is not used. The bounds check `ptr + field_length > end` in `components/api/proto.cpp` can overflow when a malicious client sends a large `field_length` value. This affects all ESPHome device platforms (ESP32, ESP8266, RP2040, LibreTiny). The overflow bypasses the out-of-bounds check, causing the device to read invalid memory and crash. When using the plaintext API protocol, this attack can be performed without authentication. When noise encryption is enabled, knowledge of the encryption key is required. Users should upgrade to ESPHome 2025.12.7 or later to receive a patch, enable API encryption with a unique key per device, and follow the Security Best Practices.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-23833?

3 open source packages ship an affected version, including esphome. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `esphome` | PyPI | From 2025.9.0 | 2025.12.7 |
| `esphome` | PyPI | From 2025.9.0 | 2025.12.7 |
| `esphome` | PyPI | From 2025.9.0 | 2025.12.7 |

Products: Esphome Esphome.

## How do I fix CVE-2026-23833?

Upgrade esphome to 2025.12.7 or later.

## Is CVE-2026-23833 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23833 exists.

## Other vulnerabilities in esphome

- [CVE-2024-27081](https://insights.sbomify.com/CVE-2024-27081/): ESPHome remote code execution via arbitrary file write (high 7.2)
- [CVE-2024-27287](https://insights.sbomify.com/CVE-2024-27287/): ESPHome vulnerable to stored Cross-site Scripting in edit configuration file API (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23833 and fix it if it is affected.

What it is: CVE-2026-23833 is a low-severity vulnerability in esphome, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23833 exists.

Affected packages and fixed versions:
- esphome (PyPI): affected from 2025.9.0; fixed in 2025.12.7
- esphome (PyPI): affected from 2025.9.0; fixed in 2025.12.7
- esphome (PyPI): affected from 2025.9.0; fixed in 2025.12.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23833/ (Markdown: https://insights.sbomify.com/CVE-2026-23833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23833
- OSV: https://osv.dev/vulnerability/CVE-2026-23833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23833/
Summaries are generated and may contain mistakes; the official description above is the record.
