# CVE-2026-23835: LobeHub Vulnerable to Improper Authorization in Presigned Upload

> Attackers can manipulate upload parameters to write files to arbitrary paths and bypass storage quotas, causing financial loss and service degradation.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 30 Jan 2026
- **Also known as:** GHSA-wrrr-8jcv-wjf5

## What is CVE-2026-23835?

CVE-2026-23835 is a medium-severity path traversal vulnerability in lobehub lobe-chat, published on 30 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LobeHub is an open source human-and-AI-agent network. Prior to version 1.143.3, the file upload feature in `Knowledge Base > File Upload` does not validate the integrity of the upload request, allowing users to intercept and modify the request parameters. As a result, it is possible to create arbitrary files in abnormal or unintended paths. In addition, since `lobechat.com` relies on the size parameter from the request to calculate file usage, an attacker can manipulate this value to misrepresent the actual file size, such as uploading a `1 GB` file while reporting it as `10 MB`, or falsely declaring a `10 MB` file as a `1 GB` file. By manipulating the size value provided in the client upload request, it is possible to bypass the monthly upload quota enforced by the server and continuously upload files beyond the intended storage and traffic limits. This abuse can result in a discrepancy between actual resource consumption and billing calculations, causing direct financial impact to the service operator. Additionally, exhaustion of storage or related resources may lead to degraded service availability, including failed uploads, delayed content delivery, or temporary suspension of upload functionality for legitimate users. A single malicious user can also negatively affect other users or projects sharing the same subscription plan, effectively causing an indirect denial of service (DoS). Furthermore, excessive and unaccounted-for uploads can distort monitoring metrics and overload downstream systems such as backup processes, malware scanning, and media processing pipelines, ultimately undermining overall operational stability and service reliability. Version 1.143.3 contains a patch for the issue.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-23835?

2 open source packages ship an affected version, including @lobehub/chat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/chat` | npm | All versions | 1.143.3 |
| `@lobehub/chat` | npm | All versions | 1.143.3 |

## How do I fix CVE-2026-23835?

Upgrade @lobehub/chat to 1.143.3 or later.

## Is CVE-2026-23835 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23835 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23835 and fix it if it is affected.

What it is: CVE-2026-23835 is a medium-severity path traversal vulnerability in lobehub lobe-chat, published on 30 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23835 exists.

Affected packages and fixed versions:
- @lobehub/chat (npm): affected all versions; fixed in 1.143.3
- @lobehub/chat (npm): affected all versions; fixed in 1.143.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23835/ (Markdown: https://insights.sbomify.com/CVE-2026-23835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23835
- OSV: https://osv.dev/vulnerability/CVE-2026-23835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23835/
Summaries are generated and may contain mistakes; the official description above is the record.
