# CVE-2026-23841: Movary vulnerable to Cross-site Scripting with `?categoryCreated=` param

> Attackers can execute arbitrary scripts via the categoryCreated parameter, potentially compromising user sessions in Movary.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-v877-x568-4v5v

## What is CVE-2026-23841?

CVE-2026-23841 is a critical cross-site scripting vulnerability in leepeuker movary, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Movary is a web application to track, rate and explore your movie watch history. Due to insufficient input validation, attackers can trigger cross-site scripting payloads in versions prior to 0.70.0. The vulnerable parameter is `?categoryCreated=`. Version 0.70.0 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-23841?

It affects 1 product.


Products: Leepeuker Movary.

## How do I fix CVE-2026-23841?

No fix has been published for CVE-2026-23841 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-23841 being exploited?

There is no known exploitation of CVE-2026-23841 in the wild and no public exploit code.

## Other vulnerabilities in leepeuker movary

- [CVE-2026-23839](https://insights.sbomify.com/CVE-2026-23839/): Movary vulnerable to Cross-site Scripting with `?categoryUpdated=` param (critical 9.3)
- [CVE-2026-23840](https://insights.sbomify.com/CVE-2026-23840/): Movary vulnerable to Cross-site Scripting with `?categoryDeleted=` param (critical 9.3)
- [CVE-2026-40349](https://insights.sbomify.com/CVE-2026-40349/): Authenticated Movary User Can Self-Escalate to Administrator via PUT /settings/users/{userId} by Setting isAdmin=true (high 8.8)
- [CVE-2026-40350](https://insights.sbomify.com/CVE-2026-40350/): Missing authorization in movary (high 8.8)
- [CVE-2026-40348](https://insights.sbomify.com/CVE-2026-40348/): Movary has Authenticated SSRF via Jellyfin Server URL Verification that Allows Internal Network Probing (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23841 and fix it if it is affected.

What it is: CVE-2026-23841 is a critical cross-site scripting vulnerability in leepeuker movary, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23841 in the wild and no public exploit code.

Affected product: leepeuker movary. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23841/ (Markdown: https://insights.sbomify.com/CVE-2026-23841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23841
- OSV: https://osv.dev/vulnerability/CVE-2026-23841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23841/
Summaries are generated and may contain mistakes; the official description above is the record.
