{"answers":{"affected":"3 open source packages ship an affected version, including chatterbot. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23842 in the wild and no public exploit code.","fix":"Upgrade chatterbot to 1.2.11 or later.","what":"CVE-2026-23842 is a high-severity denial of service vulnerability in gunthercox ChatterBot, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23842 and fix it if it is affected.\n\nWhat it is: CVE-2026-23842 is a high-severity denial of service vulnerability in gunthercox ChatterBot, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23842 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- chatterbot (PyPI): affected all versions; fixed in 1.2.11\n- chatterbot (PyPI): affected all versions; fixed in 1.2.11\n- chatterbot (PyPI): affected all versions; fixed in 1.2.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23842/ (Markdown: https://insights.sbomify.com/CVE-2026-23842/index.md)","id":"CVE-2026-23842","markdown":"https://insights.sbomify.com/CVE-2026-23842/index.md","name":"CVE-2026-23842","record":{"aliases":["GHSA-v4w8-49pv-mf72","PYSEC-2026-1244"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python chatbot library","requires_auth":"none","summary":"Attackers can cause persistent service unavailability in ChatterBot by exhausting the database connection pool through concurrent requests.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"chatterbot","vendor":"chatterbot"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"ChatterBot is a machine learning, conversational dialog engine for creating chat bots. ChatterBot versions up to 1.2.10 are vulnerable to a denial-of-service condition caused by improper database session and connection pool management. Concurrent invocations of the get_response() method can exhaust the underlying SQLAlchemy connection pool, resulting in persistent service unavailability and requiring a manual restart to recover. Version 1.2.11 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-03-01","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-03-01T08:23:17Z","kind":"github_poc","ref":"https://github.com/AdityaBhatt3010/CVE-2026-23842-Denial-of-Service-via-Database-Connection-Pool-Exhaustion-version-1.2.10","stars":2,"title":"CVE-2026-23842 — High severity Denial-of-Service vulnerability caused by SQLAlchemy connection pool exhaustion in concurrent get_response() calls in ChatterBot ≤ 1.2.10."}],"tier":"poc_unverified"},"has_fix":true,"headline":"ChatterBot has Denial of Service via Database Connection Pool Exhaustion","id":"CVE-2026-23842","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":5,"next":{"headline":"teklifolustur_app's IDOR vulnerability allows unauthorized access to other users' offers","id":"CVE-2026-23843"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"chatterbot","purl":null,"source":"GHSA-v4w8-49pv-mf72"},{"ecosystem":"PyPI","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"chatterbot","purl":"pkg:pypi/chatterbot","source":"GHSA-v4w8-49pv-mf72"},{"ecosystem":"PyPI","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"chatterbot","purl":"pkg:pypi/chatterbot","source":"PYSEC-2026-1244"}],"prev":{"headline":"Movary vulnerable to Cross-site Scripting with `?categoryCreated=` param","id":"CVE-2026-23841"},"products":["ChatterBot"],"published":"2026-01-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-20","vendors":["gunthercox"]},"summary":"Attackers can cause persistent service unavailability in ChatterBot by exhausting the database connection pool through concurrent requests.","url":"https://insights.sbomify.com/CVE-2026-23842/"}