# CVE-2026-23847: SiYuan Vulnerable to Reflected Cross-Site Scripting (XSS) via /api/icon/getDynamicIcon

> Attackers can execute arbitrary JavaScript in victim browsers via unsanitized SVG input in the dynamic icon API endpoint.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-w836-5gpm-7r93, GO-2026-4343

## What is CVE-2026-23847?

CVE-2026-23847 is a low-severity cross-site scripting vulnerability in B3log Siyuan, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SiYuan is a personal knowledge management system. Versions prior to 3.5.4 are vulnerable to reflected cross-site scripting in /api/icon/getDynamicIcon due to unsanitized SVG input. The endpoint generates SVG images for text icons (type=8). The content query parameter is inserted directly into the SVG <text> tag without XML escaping. Since the response Content-Type is image/svg+xml, injecting unescaped tags allows breaking the XML structure and executing JavaScript. Version 3.5.4 patches the issue.]

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-23847?

3 open source packages ship an affected version, including github.com/siyuan-note/siyuan/kernel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260118021606-5c0cc375b475 |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260118021606-5c0cc375b475 |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260118021606-5c0cc375b475 |

Products: B3log Siyuan.

## How do I fix CVE-2026-23847?

Upgrade github.com/siyuan-note/siyuan/kernel to 0.0.0-20260118021606-5c0cc375b475 or later.

## Is CVE-2026-23847 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23847 exists.

## Other vulnerabilities in B3log Siyuan

- [CVE-2026-32938](https://insights.sbomify.com/CVE-2026-32938/): SiYuan has an Arbitrary File Read in its Desktop Publish Service (critical 9.9)
- [CVE-2026-33669](https://insights.sbomify.com/CVE-2026-33669/): SiYuan has Arbitrary Document Reading within the Publishing Service (critical 9.8)
- [CVE-2026-33670](https://insights.sbomify.com/CVE-2026-33670/): SiYuan has directory traversal within its publishing service (critical 9.8)
- [CVE-2026-32767](https://insights.sbomify.com/CVE-2026-32767/): SiYuan: Authorization Bypass Allows Arbitrary SQL Execution via Search API (critical 9.8)
- [CVE-2024-53504](https://insights.sbomify.com/CVE-2024-53504/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23847 and fix it if it is affected.

What it is: CVE-2026-23847 is a low-severity cross-site scripting vulnerability in B3log Siyuan, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23847 exists.

Affected packages and fixed versions:
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260118021606-5c0cc375b475
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260118021606-5c0cc375b475
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260118021606-5c0cc375b475

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23847/ (Markdown: https://insights.sbomify.com/CVE-2026-23847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23847
- OSV: https://osv.dev/vulnerability/CVE-2026-23847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23847/
Summaries are generated and may contain mistakes; the official description above is the record.
