CVE-2026-23870 Facebook React has a Denial of Service Vulnerability in React Server Components
Attackers can cause server crashes or resource exhaustion by sending crafted HTTP requests to React server DOM endpoints.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23870?
CVE-2026-23870 is a high-severity denial of service vulnerability in Meta react-server-dom-parcel, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to server crashes, out-of-memory exceptions or excessive CPU usage; affecting the following packages: react-server-dom-webpack, react-server-dom-parcel, react-server-dom-turbopack (versions 19.0.0 through 19.0.5, 19.1.0 through 19.1.6, and 19.2.0 through 19.2.5).
Weakness: CWE-400
Which versions are affected by CVE-2026-23870?
18 open source packages ship an affected version, including react-server-dom-parcel, react-server-dom-turbopack and react-server-dom-webpack. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
react-server-dom-parcel npm | From 19.0.0 | 19.0.6 |
react-server-dom-parcel npm | From 19.0.0 | 19.0.6 |
react-server-dom-parcel npm | From 19.1.0 | 19.1.7 |
react-server-dom-parcel npm | From 19.1.0 | 19.1.7 |
react-server-dom-parcel npm | From 19.2.0 | 19.2.6 |
react-server-dom-parcel npm | From 19.2.0 | 19.2.6 |
12 more packages
react-server-dom-turbopack npm | From 19.0.0 | 19.0.6 |
react-server-dom-turbopack npm | From 19.0.0 | 19.0.6 |
react-server-dom-turbopack npm | From 19.1.0 | 19.1.7 |
react-server-dom-turbopack npm | From 19.1.0 | 19.1.7 |
react-server-dom-turbopack npm | From 19.2.0 | 19.2.6 |
react-server-dom-turbopack npm | From 19.2.0 | 19.2.6 |
react-server-dom-webpack npm | From 19.0.0 | 19.0.6 |
react-server-dom-webpack npm | From 19.0.0 | 19.0.6 |
react-server-dom-webpack npm | From 19.1.0 | 19.1.7 |
react-server-dom-webpack npm | From 19.1.0 | 19.1.7 |
react-server-dom-webpack npm | From 19.2.0 | 19.2.6 |
react-server-dom-webpack npm | From 19.2.0 | 19.2.6 |
Products include Facebook React-Server-Dom-Parcel, Facebook React-Server-Dom-Turbopack, Facebook React-Server-Dom-Webpack.
How do I fix CVE-2026-23870?
Upgrade react-server-dom-parcel to a fixed version for your release line: 19.0.6, 19.1.7 or 19.2.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-23870 being exploited?
There is no known exploitation of CVE-2026-23870 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Sources
Also known as GHSA-rv78-f8rc-xrxh.