# CVE-2026-23870: Facebook React has a Denial of Service Vulnerability in React Server Components

> Attackers can cause server crashes or resource exhaustion by sending crafted HTTP requests to React server DOM endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-rv78-f8rc-xrxh

## What is CVE-2026-23870?

CVE-2026-23870 is a high-severity denial of service vulnerability in Meta react-server-dom-parcel, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to server crashes, out-of-memory exceptions or excessive CPU usage; affecting the following packages: react-server-dom-webpack, react-server-dom-parcel, react-server-dom-turbopack (versions 19.0.0 through 19.0.5, 19.1.0 through 19.1.6, and 19.2.0 through 19.2.5).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-23870?

18 open source packages ship an affected version, including react-server-dom-parcel, react-server-dom-turbopack and react-server-dom-webpack. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-server-dom-parcel` | npm | From 19.0.0 | 19.0.6 |
| `react-server-dom-parcel` | npm | From 19.0.0 | 19.0.6 |
| `react-server-dom-parcel` | npm | From 19.1.0 | 19.1.7 |
| `react-server-dom-parcel` | npm | From 19.1.0 | 19.1.7 |
| `react-server-dom-parcel` | npm | From 19.2.0 | 19.2.6 |
| `react-server-dom-parcel` | npm | From 19.2.0 | 19.2.6 |
| `react-server-dom-turbopack` | npm | From 19.0.0 | 19.0.6 |
| `react-server-dom-turbopack` | npm | From 19.0.0 | 19.0.6 |
| `react-server-dom-turbopack` | npm | From 19.1.0 | 19.1.7 |
| `react-server-dom-turbopack` | npm | From 19.1.0 | 19.1.7 |
| `react-server-dom-turbopack` | npm | From 19.2.0 | 19.2.6 |
| `react-server-dom-turbopack` | npm | From 19.2.0 | 19.2.6 |
| `react-server-dom-webpack` | npm | From 19.0.0 | 19.0.6 |
| `react-server-dom-webpack` | npm | From 19.0.0 | 19.0.6 |
| `react-server-dom-webpack` | npm | From 19.1.0 | 19.1.7 |
| `react-server-dom-webpack` | npm | From 19.1.0 | 19.1.7 |
| `react-server-dom-webpack` | npm | From 19.2.0 | 19.2.6 |
| `react-server-dom-webpack` | npm | From 19.2.0 | 19.2.6 |

Products: Facebook React-Server-Dom-Parcel, Facebook React-Server-Dom-Turbopack, Facebook React-Server-Dom-Webpack.

## How do I fix CVE-2026-23870?

Upgrade react-server-dom-parcel to a fixed version for your release line: 19.0.6, 19.1.7 or 19.2.6.

## Is CVE-2026-23870 being exploited?

There is no known exploitation of CVE-2026-23870 in the wild and no public exploit code.

Public exploit code:

- Next.js v16.2.4 Security PoC Collection (CVE-2026-23870, CVE-2026-44575, CVE-2026-44579, CVE-2026-44574, CVE-2026-44578, CVE-2026-44573, CVE-2026-44581, CVE-2026-44580, CVE-2026-44577, CVE-2026-44576, CVE-2026-44582, CVE-2026-44572) (github_poc): https://github.com/dwisiswant0/next-16.2.4-pocs
- Checker and fixer for all 13 vulnerabilities in the Next.js May 2026 security release (CVE-2026-23870) (github_poc): https://github.com/emresandikci/nextjs-cve-2026-23870-checker

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23870 and fix it if it is affected.

What it is: CVE-2026-23870 is a high-severity denial of service vulnerability in Meta react-server-dom-parcel, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23870 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-server-dom-parcel (npm): affected from 19.0.0; fixed in 19.0.6
- react-server-dom-parcel (npm): affected from 19.0.0; fixed in 19.0.6
- react-server-dom-parcel (npm): affected from 19.1.0; fixed in 19.1.7
- react-server-dom-parcel (npm): affected from 19.1.0; fixed in 19.1.7
- react-server-dom-parcel (npm): affected from 19.2.0; fixed in 19.2.6
- react-server-dom-parcel (npm): affected from 19.2.0; fixed in 19.2.6
- react-server-dom-turbopack (npm): affected from 19.0.0; fixed in 19.0.6
- react-server-dom-turbopack (npm): affected from 19.0.0; fixed in 19.0.6
- react-server-dom-turbopack (npm): affected from 19.1.0; fixed in 19.1.7
- react-server-dom-turbopack (npm): affected from 19.1.0; fixed in 19.1.7
- react-server-dom-turbopack (npm): affected from 19.2.0; fixed in 19.2.6
- react-server-dom-turbopack (npm): affected from 19.2.0; fixed in 19.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23870/ (Markdown: https://insights.sbomify.com/CVE-2026-23870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23870
- OSV: https://osv.dev/vulnerability/CVE-2026-23870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23870/
Summaries are generated and may contain mistakes; the official description above is the record.
