CVE-2026-23881 Kyverno Denial of Service via Context Variable Amplification in Policy Engine
Attackers with policy creation privileges can cause denial of service in Kyverno by crafting policies that exponentially amplify string data through context variables.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23881?
CVE-2026-23881 is a high-severity denial of service vulnerability in kyverno, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kyverno is a policy engine designed for cloud native platform engineering teams. Versions prior to 1.16.3 and 1.15.3 have unbounded memory consumption in Kyverno's policy engine that allows users with policy creation privileges to cause denial of service by crafting policies that exponentially amplify string data through context variables. Versions 1.16.3 and 1.15.3 contain a patch for the vulnerability.
Weakness: CWE-770
Which versions are affected by CVE-2026-23881?
6 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/kyverno/kyverno Go | All versions | 1.15.3, 1.16.3 |
github.com/kyverno/kyverno Go | All versions | 1.15.3 |
github.com/kyverno/kyverno Go | All versions | 1.15.3 |
github.com/kyverno/kyverno Go | From 1.16.0-rc.1 | 1.16.3 |
github.com/kyverno/kyverno Go | From 1.16.0-rc.1 | 1.16.3 |
kyverno Bitnami | All versions | 1.15.3, 1.16.3 |
Products include Kyverno Kyverno.
How do I fix CVE-2026-23881?
Upgrade github.com/kyverno/kyverno to a fixed version for your release line: 1.15.3 or 1.16.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-23881 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23881 exists.
Other vulnerabilities in kyverno
- CVE-2026-22039 Kyverno Cross-Namespace Privilege Escalation via Policy apiCall
- CVE-2026-4789 CVE-2026-4789
- CVE-2025-46342 Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements
- CVE-2026-41323 Kyverno: ServiceAccount token leaked to external servers via apiCall service URL
- CVE-2026-40868 kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token
Sources
Also known as BIT-kyverno-2026-23881, CLEANSTART-2026-EE99058, GHSA-r2rj-wwm5-x6mq, GO-2026-4382, MINI-343x-q66f-r7jh, MINI-34qf-6fq6-w5q6 and 11 more.