# CVE-2026-23881: Kyverno Denial of Service via Context Variable Amplification in Policy Engine

> Attackers with policy creation privileges can cause denial of service in Kyverno by crafting policies that exponentially amplify string data through context variables.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** BIT-kyverno-2026-23881, CLEANSTART-2026-EE99058, GHSA-r2rj-wwm5-x6mq, GO-2026-4382, MINI-343x-q66f-r7jh, MINI-34qf-6fq6-w5q6, MINI-4xcw-7r24-ffg5, MINI-5f2f-4437-87vq, MINI-7wxp-93x4-296g, MINI-979x-ghp6-2cmh, MINI-9xg9-mv59-hc47, MINI-cx7p-vvcr-q7r5, MINI-jjx7-76j8-258m, MINI-p4rv-3h92-vhv7, MINI-v2jq-v486-4j9c, MINI-wjcq-9qg7-qmcg, MINI-wmwr-392f-v3wp

## What is CVE-2026-23881?

CVE-2026-23881 is a high-severity denial of service vulnerability in kyverno, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. Versions prior to 1.16.3 and 1.15.3 have unbounded memory consumption in Kyverno's policy engine that allows users with policy creation privileges to cause denial of service by crafting policies that exponentially amplify string data through context variables. Versions 1.16.3 and 1.15.3 contain a patch for the vulnerability.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-23881?

6 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.15.3, 1.16.3 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.15.3 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.15.3 |
| `github.com/kyverno/kyverno` | Go | From 1.16.0-rc.1 | 1.16.3 |
| `github.com/kyverno/kyverno` | Go | From 1.16.0-rc.1 | 1.16.3 |
| `kyverno` | Bitnami | All versions | 1.15.3, 1.16.3 |

Products: Kyverno Kyverno.

## How do I fix CVE-2026-23881?

Upgrade github.com/kyverno/kyverno to a fixed version for your release line: 1.15.3 or 1.16.3.

## Is CVE-2026-23881 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23881 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23881 and fix it if it is affected.

What it is: CVE-2026-23881 is a high-severity denial of service vulnerability in kyverno, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23881 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.15.3, 1.16.3
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.15.3
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.15.3
- github.com/kyverno/kyverno (Go): affected from 1.16.0-rc.1; fixed in 1.16.3
- github.com/kyverno/kyverno (Go): affected from 1.16.0-rc.1; fixed in 1.16.3
- kyverno (Bitnami): affected all versions; fixed in 1.15.3, 1.16.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23881/ (Markdown: https://insights.sbomify.com/CVE-2026-23881/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23881
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23881
- OSV: https://osv.dev/vulnerability/CVE-2026-23881

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23881/
Summaries are generated and may contain mistakes; the official description above is the record.
