CVE-2026-23885 AlchemyCMS has Authenticated Remote Code Execution (RCE) via eval injection in ResourcesHelper
Authenticated attackers can execute arbitrary system commands via eval injection in AlchemyCMS, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23885?
CVE-2026-23885 is a medium-severity code injection vulnerability in AlchemyCMS alchemy_cms, published on 19 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Alchemy is an open source content management system engine written in Ruby on Rails. Prior to versions 7.4.12 and 8.0.3, the application uses the Ruby `eval()` function to dynamically execute a string provided by the `resource_handler.engine_name` attribute in `Alchemy::ResourcesHelper#resource_url_proxy`. The vulnerability exists in `app/helpers/alchemy/resources_helper.rb` at line 28. The code explicitly bypasses security linting with `# rubocop:disable Security/Eval`, indicating that the use of a dangerous function was known but not properly mitigated. Since `engine_name` is sourced from module definitions that can be influenced by administrative configurations, it allows an authenticated attacker to escape the Ruby sandbox and execute arbitrary system commands on the host OS. Versions 7.4.12 and 8.0.3 fix the issue by replacing `eval()` with `send()`.
Weakness: CWE-95
Which versions are affected by CVE-2026-23885?
4 open source packages ship an affected version, including alchemy_cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
alchemy_cms RubyGems | All versions | 7.4.12 |
alchemy_cms RubyGems | All versions | 7.4.12 |
alchemy_cms RubyGems | From 8.0.0.a | 8.0.3 |
alchemy_cms RubyGems | From 8.0.0.a | 8.0.3 |
Products include Alchemy-Cms Alchemy Cms.
How do I fix CVE-2026-23885?
Upgrade alchemy_cms to a fixed version for your release line: 7.4.12 or 8.0.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-23885 being exploited?
There is no known exploitation of CVE-2026-23885 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in AlchemyCMS alchemy_cms
Sources
Also known as GHSA-2762-657x-v979.