# CVE-2026-23888: pnpm: Binary ZIP extraction allows arbitrary file write via path traversal (Zip Slip)

> Malicious packages can write files outside the extraction directory via path traversal, potentially leading to remote code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-6pfh-p556-v868, MINI-ghq9-c9r5-p326

## What is CVE-2026-23888?

CVE-2026-23888 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to version 10.28.1, a path traversal vulnerability in pnpm's binary fetcher allows malicious packages to write files outside the intended extraction directory. The vulnerability has two attack vectors: (1) Malicious ZIP entries containing `../` or absolute paths that escape the extraction root via AdmZip's `extractAllTo`, and (2) The `BinaryResolution.prefix` field is concatenated into the extraction path without validation, allowing a crafted prefix like `../../evil` to redirect extracted files outside `targetDir`. The issue impacts all pnpm users who install packages with binary assets, users who configure custom Node.js binary locations and CI/CD pipelines that auto-install binary dependencies. It can lead to overwriting config files, scripts, or other sensitive files leading to RCE. Version 10.28.1 contains a patch.

Weakness: CWE-426 (Untrusted Search Path), CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-23888?

2 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.28.1 |
| `pnpm` | npm | All versions | 10.28.1 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-23888?

Upgrade pnpm to 10.28.1 or later.

## Is CVE-2026-23888 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23888 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23888 and fix it if it is affected.

What it is: CVE-2026-23888 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23888 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.28.1
- pnpm (npm): affected all versions; fixed in 10.28.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23888/ (Markdown: https://insights.sbomify.com/CVE-2026-23888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23888
- OSV: https://osv.dev/vulnerability/CVE-2026-23888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23888/
Summaries are generated and may contain mistakes; the official description above is the record.
