# CVE-2026-23890: pnpm scoped bin name Path Traversal allows arbitrary file creation outside node_modules/.bin

> Malicious npm packages can create executable shims outside node_modules/.bin via path traversal, potentially overwriting sensitive files or executing code.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-xpqm-wm3m-f34h, MINI-jf6x-jwgj-v89m

## What is CVE-2026-23890?

CVE-2026-23890 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to version 10.28.1, a path traversal vulnerability in pnpm's bin linking allows malicious npm packages to create executable shims or symlinks outside of `node_modules/.bin`. Bin names starting with `@` bypass validation, and after scope normalization, path traversal sequences like `../../` remain intact. This issue affects all pnpm users who install npm packages and CI/CD pipelines using pnpm. It can lead to overwriting config files, scripts, or other sensitive files. Version 10.28.1 contains a patch.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-23890?

2 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.28.1 |
| `pnpm` | npm | All versions | 10.28.1 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-23890?

Upgrade pnpm to 10.28.1 or later.

## Is CVE-2026-23890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23890 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23890 and fix it if it is affected.

What it is: CVE-2026-23890 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23890 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.28.1
- pnpm (npm): affected all versions; fixed in 10.28.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23890/ (Markdown: https://insights.sbomify.com/CVE-2026-23890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23890
- OSV: https://osv.dev/vulnerability/CVE-2026-23890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23890/
Summaries are generated and may contain mistakes; the official description above is the record.
