CVE-2026-23891 Decidim has a Cross-site scripting (XSS) vulnerability via user name field
A stored XSS vulnerability in Decidim allows attackers to execute arbitrary code in the context of other users visiting comment pages.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-23891?
CVE-2026-23891 is a critical cross-site scripting vulnerability in decidim, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-23891?
4 open source packages ship an affected version, including decidim-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
decidim-core RubyGems | All versions | 0.30.5 |
decidim-core RubyGems | All versions | 0.30.5 |
decidim-core RubyGems | From 0.31.0.rc1 | 0.31.1 |
decidim-core RubyGems | From 0.31.0.rc1 | 0.31.1 |
Products include Decidim Decidim.
How do I fix CVE-2026-23891?
Upgrade decidim-core to a fixed version for your release line: 0.30.5 or 0.31.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-23891 being exploited?
There is no known exploitation of CVE-2026-23891 in the wild and no public exploit code.
Other vulnerabilities in decidim
- CVE-2023-36465 Decidim has broken access control in templates
- CVE-2025-65017 Decidim's private data exports can lead to data leaks
- CVE-2023-32693 Decidim Cross-site Scripting vulnerability in the external link redirections
- CVE-2023-34089 Decidim Cross-site Scripting vulnerability in the processes filter
- CVE-2024-45594 Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds
Sources
Also known as GHSA-fc46-r95f-hq7g.