{"answers":{"affected":"4 open source packages ship an affected version, including decidim-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23891 in the wild and no public exploit code.","fix":"Upgrade decidim-core to a fixed version for your release line: 0.30.5 or 0.31.1.","what":"CVE-2026-23891 is a critical cross-site scripting vulnerability in decidim, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-23891 and fix it if it is affected.\n\nWhat it is: CVE-2026-23891 is a critical cross-site scripting vulnerability in decidim, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-23891 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-core (RubyGems): affected all versions; fixed in 0.30.5\n- decidim-core (RubyGems): affected all versions; fixed in 0.30.5\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1\n- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23891/ (Markdown: https://insights.sbomify.com/CVE-2026-23891/index.md)","id":"CVE-2026-23891","markdown":"https://insights.sbomify.com/CVE-2026-23891/index.md","name":"CVE-2026-23891","record":{"aliases":["GHSA-fc46-r95f-hq7g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"low_privilege","summary":"A stored XSS vulnerability in Decidim allows attackers to execute arbitrary code in the context of other users visiting comment pages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"OctoPrint has Timing Side-Channel Vulnerability in API Key Authentication","id":"CVE-2026-23892"},"packages":[{"ecosystem":"RubyGems","fixed":["0.30.5"],"introduced":["0"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-fc46-r95f-hq7g"},{"ecosystem":"RubyGems","fixed":["0.30.5"],"introduced":["0"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-fc46-r95f-hq7g"},{"ecosystem":"RubyGems","fixed":["0.31.1"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-fc46-r95f-hq7g"},{"ecosystem":"RubyGems","fixed":["0.31.1"],"introduced":["0.31.0.rc1"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-fc46-r95f-hq7g"}],"prev":{"headline":"pnpm scoped bin name Path Traversal allows arbitrary file creation outside node_modules/.bin","id":"CVE-2026-23890"},"products":["decidim"],"published":"2026-04-13","related":[{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-14","vendors":["decidim"]},"summary":"A stored XSS vulnerability in Decidim allows attackers to execute arbitrary code in the context of other users visiting comment pages.","url":"https://insights.sbomify.com/CVE-2026-23891/"}