# CVE-2026-23891: Decidim has a Cross-site scripting (XSS) vulnerability via user name field

> A stored XSS vulnerability in Decidim allows attackers to execute arbitrary code in the context of other users visiting comment pages.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-fc46-r95f-hq7g

## What is CVE-2026-23891?

CVE-2026-23891 is a critical cross-site scripting vulnerability in decidim, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-23891?

4 open source packages ship an affected version, including decidim-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-core` | RubyGems | All versions | 0.30.5 |
| `decidim-core` | RubyGems | All versions | 0.30.5 |
| `decidim-core` | RubyGems | From 0.31.0.rc1 | 0.31.1 |
| `decidim-core` | RubyGems | From 0.31.0.rc1 | 0.31.1 |

Products: Decidim Decidim.

## How do I fix CVE-2026-23891?

Upgrade decidim-core to a fixed version for your release line: 0.30.5 or 0.31.1.

## Is CVE-2026-23891 being exploited?

There is no known exploitation of CVE-2026-23891 in the wild and no public exploit code.

## Other vulnerabilities in decidim

- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2025-65017](https://insights.sbomify.com/CVE-2025-65017/): Decidim's private data exports can lead to data leaks (high 8.2)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)
- [CVE-2024-45594](https://insights.sbomify.com/CVE-2024-45594/): Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23891 and fix it if it is affected.

What it is: CVE-2026-23891 is a critical cross-site scripting vulnerability in decidim, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23891 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-core (RubyGems): affected all versions; fixed in 0.30.5
- decidim-core (RubyGems): affected all versions; fixed in 0.30.5
- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1
- decidim-core (RubyGems): affected from 0.31.0.rc1; fixed in 0.31.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23891/ (Markdown: https://insights.sbomify.com/CVE-2026-23891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23891
- OSV: https://osv.dev/vulnerability/CVE-2026-23891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23891/
Summaries are generated and may contain mistakes; the official description above is the record.
