# CVE-2026-23892: OctoPrint has Timing Side-Channel Vulnerability in API Key Authentication

> Attackers can potentially extract API keys via timing side-channels in OctoPrint, allowing unauthorized access to 3D printer controls.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-xg4x-w2j3-57h6, PYSEC-2026-1716

## What is CVE-2026-23892?

CVE-2026-23892 is a medium-severity vulnerability in OctoPrint, published on 27 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up to and including 1.11.5 are affected by a (theoretical) timing attack vulnerability that allows API key extraction over the network. Due to using character based comparison that short-circuits on the first mismatched character during API key validation, rather than a cryptographical method with static runtime regardless of the point of mismatch, an attacker with network based access to an affected OctoPrint could extract API keys valid on the instance by measuring the response times of the denied access responses and guess an API key character by character. The vulnerability is patched in version 1.11.6. The likelihood of this attack actually working is highly dependent on the network's latency, noise and similar parameters. An actual proof of concept was not achieved so far. Still, as always administrators are advised to not expose their OctoPrint instance on hostile networks, especially not on the public Internet.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-23892?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.11.6 |
| `octoprint` | PyPI | All versions | 1.11.6 |
| `OctoPrint` | PyPI | All versions | 1.11.6 |

Products: Octoprint Octoprint.

## How do I fix CVE-2026-23892?

Upgrade octoprint to 1.11.6 or later.

## Is CVE-2026-23892 being exploited?

There is no known exploitation of CVE-2026-23892 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23892 and fix it if it is affected.

What it is: CVE-2026-23892 is a medium-severity vulnerability in OctoPrint, published on 27 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23892 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.11.6
- octoprint (PyPI): affected all versions; fixed in 1.11.6
- OctoPrint (PyPI): affected all versions; fixed in 1.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23892/ (Markdown: https://insights.sbomify.com/CVE-2026-23892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23892
- OSV: https://osv.dev/vulnerability/CVE-2026-23892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23892/
Summaries are generated and may contain mistakes; the official description above is the record.
