{"answers":{"affected":"6 open source packages ship an affected version, including apollo-server and @apollo/server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23897 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-23897 is a high-severity denial of service vulnerability in apollographql apollo-server, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23897 and fix it if it is affected.\n\nWhat it is: CVE-2026-23897 is a high-severity denial of service vulnerability in apollographql apollo-server, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23897 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apollo-server (npm): affected from 2.0.0 up to 3.13.0; no fix listed\n- apollo-server (npm): affected from 2.0.0 up to 3.13.0; no fix listed\n- @apollo/server (npm): affected from 4.2.0; fixed in 4.13.0\n- @apollo/server (npm): affected from 4.2.0; fixed in 4.13.0\n- @apollo/server (npm): affected from 5.0.0; fixed in 5.4.0\n- @apollo/server (npm): affected from 5.0.0; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23897/ (Markdown: https://insights.sbomify.com/CVE-2026-23897/index.md)","id":"CVE-2026-23897","markdown":"https://insights.sbomify.com/CVE-2026-23897/index.md","name":"CVE-2026-23897","record":{"aliases":["GHSA-mp6q-xf9x-fwf7","ROOT-APP-NPM-CVE-2026-23897"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL server library","requires_auth":"none","summary":"Attackers can cause denial of service in Apollo Server standalone mode via crafted request bodies with exotic encodings.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apollo_server","vendor":"apollographql"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo Server is vulnerable to denial of service with `startStandaloneServer`","id":"CVE-2026-23897","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":3,"next":{"headline":"Joomla! Core - [20260305] - Arbitrary file deletion in com_joomlaupdate","id":"CVE-2026-23898"},"packages":[{"ecosystem":"npm","fixed":["4.13.0"],"introduced":["4.2.0"],"last_affected":[],"package":"@apollo/server","purl":null,"source":"GHSA-mp6q-xf9x-fwf7"},{"ecosystem":"npm","fixed":["4.13.0"],"introduced":["4.2.0"],"last_affected":[],"package":"@apollo/server","purl":"pkg:npm/%40apollo/server","source":"GHSA-mp6q-xf9x-fwf7"},{"ecosystem":"npm","fixed":["5.4.0"],"introduced":["5.0.0"],"last_affected":[],"package":"@apollo/server","purl":null,"source":"GHSA-mp6q-xf9x-fwf7"},{"ecosystem":"npm","fixed":["5.4.0"],"introduced":["5.0.0"],"last_affected":[],"package":"@apollo/server","purl":"pkg:npm/%40apollo/server","source":"GHSA-mp6q-xf9x-fwf7"},{"ecosystem":"npm","fixed":[],"introduced":["2.0.0"],"last_affected":["3.13.0"],"package":"apollo-server","purl":null,"source":"GHSA-mp6q-xf9x-fwf7"},{"ecosystem":"npm","fixed":[],"introduced":["2.0.0"],"last_affected":["3.13.0"],"package":"apollo-server","purl":"pkg:npm/apollo-server","source":"GHSA-mp6q-xf9x-fwf7"}],"prev":{"headline":"immich API Key Privilege Escalation vulnerability","id":"CVE-2026-23896"},"products":["apollo-server"],"published":"2026-02-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-04","vendors":["apollographql"]},"summary":"Attackers can cause denial of service in Apollo Server standalone mode via crafted request bodies with exotic encodings.","url":"https://insights.sbomify.com/CVE-2026-23897/"}